summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.12.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 62ca630c6e1f..198fe9b57807 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.11.5.tar.xz 23168 BLAKE2B 74d10be7c303d0b7d1d8765e08a89986b4c1745e5f601982dd406cefc7c73ac684c1c05acdd355d45f5078e034ab9971467b4b76c0ae3a94800ce6480fa8c3f0 SHA512 34a8fe5da983a0fcc6d5d223120f2d23e0168a534d29941e83024110eafe981d6c46ee503abfb7bf8e072dc64060eea373c191ef0f8dbc5051cb2d968e6d49d3
DIST ksshaskpass-5.12.4.tar.xz 21060 BLAKE2B 45f157eaeffbe61d76972f08cf38ea3e659a5d89877a0e10b4dd285992c3fb89a114a5fbcceeb31e37536b39b3a9b2fb8e1cf247fc7593e135ac9374ae28354c SHA512 12b0cd5270509325d60060b3ee3a6a03fda27063fa25af6e6fbec190319a836dd11d73b202909c733137e95528e0e23b4cc35dbe2c6ad3148ad2bb63e21363fb
+DIST ksshaskpass-5.12.5.tar.xz 21200 BLAKE2B 70d134502538dc5aed5ff8d65a1b5c3c3f9e714f849e9cd9b66f43b170db4ea4e23c2a011ad2dec81d05bc26090e64453b592a5677969a2b3ed812e7d1459f4a SHA512 4e798ac709d656104cddcb637aaf352c3f55660256f7edecd2caa6c78cb2ccba065c1c9e17e39a14fab72ca760c18b729035598fc6f9055fa1a6d6b9fe6ea453
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.12.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.12.5.ebuild
new file mode 100644
index 000000000000..3009c8d5ff69
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.12.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}