summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest3
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.27.11.ebuild (renamed from kde-plasma/kwallet-pam/kwallet-pam-5.27.5.ebuild)2
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild37
3 files changed, 40 insertions, 2 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index b7896c93d41b..7f1063986c78 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
-DIST kwallet-pam-5.27.5.tar.xz 23024 BLAKE2B d1d4c54b041ad1e17040c8bf5c2725e77a9931681ecf8d62aba608a535873f534eb647fad3b1d8b5ae71e2a910d122c25e467aee9e67ae32eea540701650b918 SHA512 175e13515ee63f6963adc81460447d14d0ea021cce3bd3ebd3b5ade4e82ff76b614f55fc8620c0b37d69a56a28680aaec849cf48b45173accdecb5d6efd366fc
+DIST kwallet-pam-5.27.11.tar.xz 22948 BLAKE2B 1c0cf86bb7e57696e44ac34a4392d1f81a6ade8fbaef6c61eefc79df39890aa1799ddbb39ec59fbde3ea4536c1113c1147b28bcdfc898049e847af99b107267b SHA512 b52177df434bf71214874a2410637240bb5a23f0fd06d41f3b62630d90e5262a231012c4f11119f96c151bb222e73652e5e8506ccc26c7cc451090f3bd156b6a
+DIST kwallet-pam-6.0.4.tar.xz 23016 BLAKE2B cd1abeb02c7d734db35848318613cfff54b98c7e06c8ec3ced237bcdf154d4808c5e5e7c04d70a7469f479566e9cc12626e038b40735b7d8004cd03797c4a406 SHA512 af186165fe2e2ada5e1dd8359b41980af36e18b5266048fd3dbeeb4e2815ec158a1d1079d0c25ea427dc4c43414bf985c8eea828eafe54d9c58bc4b3c59255c6
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.27.5.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.27.11.ebuild
index 8f722261e223..44a9bab4e37f 100644
--- a/kde-plasma/kwallet-pam/kwallet-pam-5.27.5.ebuild
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.27.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild
new file mode 100644
index 000000000000..cb964d02d812
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}