summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.14.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index d07f08ef635b..655a6a462162 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.14.3.tar.xz 54088 BLAKE2B 743e4e1083339f3b78cffbd66a54d0363c05b2ca0dd3e456c180b0a39b880c9f6f07fd522e1993e35247dbaaeb330671da44462a0e156c84cfc10619ed642e98 SHA512 8078936e3db9c24a5ea05aaa826b5a69a4f12ae36e7c7e958776dc5b1d12d1d29a45a7f4ebd4f030409f7ecdb40e1f1a57bc859bd75a1ed6106ed74a122b2e23
DIST plasma-integration-5.14.4.tar.xz 54180 BLAKE2B 4c0be1d2e0aa28ad66ed1c9ee2d12005cc688250b0674951304749e688434d5de04c739e5ec3166c4bd3b39d59a61853d2ae245607aa930d38554f1efdd1878f SHA512 6ec1846ead6164ac285128d1881a914d711d4c839edca449961af413606adbe622d741514f88d63b7393931864d3f325293d4950e37934e69f4e6bb7ff5305ac
+DIST plasma-integration-5.14.5.tar.xz 54192 BLAKE2B f032456177475eb9db60dd8d1499693dbd35480df3e2150e1a073da82a41d934459d52620ac4ff7cc52d64473b38da3ab2e66b433ab89be18d746014d6936153 SHA512 6169066cf8afc96f7a595a0ac1c54785ea8f7cfbd609d30b8aa8a12586256575746318765c92038c18ab976ee064a190b1131f01f4c336e13d71a1cdfa719429
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.14.5.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.14.5.ebuild
new file mode 100644
index 000000000000..7dd94729902d
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.14.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"