summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.7.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 34c03aa61f8c..160c8abb0cb1 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.6.5.tar.xz 52552 SHA256 40e8716f3472d1a2b22bc44d51d76901c8ce0606e7587b549584cb7e9e1c87e8 SHA512 a8952f25ed2eacc96c7957c4f2d21397fe5a75a9dcfacca67e3b7111095be380128c4663276bba838cb30e877f02ded184867e29ad591fd62caed63114a79eed WHIRLPOOL 2af37abc93c7534642a93726c60fa5cd6e4095b65d8a7c0e192864c9529a04962ef84cf5ab0961711b6dc39bdd93a71367181ee2a2f415e8ba8d3614470e70d1
DIST plasma-integration-5.7.2.tar.xz 48956 SHA256 cfd8a328041a6793a17f20e9502cece94d7f302d395468a49f87b6de00030ac9 SHA512 fc01a157987dc9f7d60d2c8b5aa334e1c994db785bb39d613845e57fca6163e7739ce50a4a0352a367e4561a959cb44cea7749a239fe9fbc3707bab2b59be3f1 WHIRLPOOL b46426a48edfd099d9336dbaefb0488af452081b1b9ec26c531ee24bae1563fc1ccf6d38cbe205f058dc0b2af6c7d5f0b6859fb5342339a322cc0d206a19f03c
+DIST plasma-integration-5.7.3.tar.xz 48960 SHA256 140e38073ab90c4deb11ac06586a9ea355d9637068ae8df45dc4994a9cac9cf2 SHA512 390a07b87b01ec70a0f3f4f70f17d13954b9b1fd4147a6b3ab3687bc25c900b4287a8917397fcbdbdcc5c6d1425b12202e43a21cc6f9fd941d5e4a84d000b3a2 WHIRLPOOL 2470e3d50130ce066fd22701fc89f76c3e67a3f0a9434360a3d7f560463055cfe547131e2d1ebb4bbb53a035e9b7833ee4eb13216c93be87494bf73a6911c457
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.7.3.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.7.3.ebuild
new file mode 100644
index 000000000000..d6c4ad63e6ff
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep oxygen-fonts '' 5.4.3)
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT="test"