summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-sdk')
-rw-r--r--kde-plasma/plasma-sdk/Manifest1
-rw-r--r--kde-plasma/plasma-sdk/plasma-sdk-5.12.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-plasma/plasma-sdk/Manifest b/kde-plasma/plasma-sdk/Manifest
index 80a9ca31a289..cd751d739f34 100644
--- a/kde-plasma/plasma-sdk/Manifest
+++ b/kde-plasma/plasma-sdk/Manifest
@@ -1 +1,2 @@
DIST plasma-sdk-5.11.5.tar.xz 265048 BLAKE2B 3da4125bb0db4801462ce5907329dc95a4102dacb0d09e404dd0af85d7dfeae44d4be6b60de6828999769c631c1ad09a52359501d7e9454c18ea2d91757df367 SHA512 b7259e5d17f209edf3bf07a37fb7a2efd0be08a5d34ab78115c55f94c74862e076cf58446ce67327c8021800086d282587cbec0e7ab8634b12ed009de3c26090
+DIST plasma-sdk-5.12.0.tar.xz 250056 BLAKE2B bfc4c1009a86b6f11f035151dbd92bb2f94c502a916ef4e22e74737f5cbb05f56e0a3c15f533f2904f009d5edf07f076d401116ff49a5f5200e2d24ac839760d SHA512 5a80ed04c4cc0e99e3721705ecad9e8144ec45a0888b09a41caeada9a8d1b2d9e8daaff7cb77da9fb511c192bd06913c979793ad0dab38c1277eec480a5f7d7d
diff --git a/kde-plasma/plasma-sdk/plasma-sdk-5.12.0.ebuild b/kde-plasma/plasma-sdk/plasma-sdk-5.12.0.ebuild
new file mode 100644
index 000000000000..47de95ae2130
--- /dev/null
+++ b/kde-plasma/plasma-sdk/plasma-sdk-5.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Useful applications for Plasma development"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+RDEPEND="${DEPEND}
+ !dev-util/plasmate
+ $(add_frameworks_dep kirigami)
+"