summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/files/plasma-integration-5.19.5-use-standard-kde-shortcut-for-move-to-trash.patch34
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.19.5-r1.ebuild50
3 files changed, 0 insertions, 85 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 7d7c14e860c8..574dfc2c6a67 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1 @@
-DIST plasma-integration-5.19.5.tar.xz 57464 BLAKE2B ef5ec9f849087ae738a1ff1de14a77994b4486f89b632777caa8e0aad67cad8553bdf1d0553893361ab4c11ddba0caf32464cb49f08047cf2d40375f789c166e SHA512 9e17e1720e5d5c1d3cada3f1eb891d27fd189eb65378c2e0be6547c79d93d5df2f785a3c67d35a4a374d320b118ad3b7d3fb7d968a7f5b629e505d21c83cfe36
DIST plasma-integration-5.20.5.tar.xz 59740 BLAKE2B 8c6e054db3047093556ac9549ebe28e6270001838f28eea92138f4acc02c79235f6c0ab8d82de764dae16efa81cc7ff7519736935bd77153612ee035f7abf337 SHA512 fa0806c756d394ab6f419252396f9d0a18652ed652adcb016dd2885f5238df843814f4661c63b193805834dcd43cb346f69ce33339520229c215d2ff45a24604
diff --git a/kde-plasma/plasma-integration/files/plasma-integration-5.19.5-use-standard-kde-shortcut-for-move-to-trash.patch b/kde-plasma/plasma-integration/files/plasma-integration-5.19.5-use-standard-kde-shortcut-for-move-to-trash.patch
deleted file mode 100644
index 7405dace6be1..000000000000
--- a/kde-plasma/plasma-integration/files/plasma-integration-5.19.5-use-standard-kde-shortcut-for-move-to-trash.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 15c7926377065da0fea111be303816dca91d087a Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Tue, 15 Sep 2020 13:31:48 -0600
-Subject: [PATCH] Use KDE shortcuts for "move to trash" action coming from
- QStandardKey
-
-QKeySequence::Delete is the Qt "Move to trash" action, which, by
-default, includes Ctrl+D as a shortcut. This is something we don't want
-in KDE software, so we need to intercept this action in our integration
-plugin and give it the standard KDE shortcuts instead, as we do for
-other actions.
-
-BUG: 426573
-FIXED-IN: 5.20
----
- src/platformtheme/kdeplatformtheme.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/platformtheme/kdeplatformtheme.cpp b/src/platformtheme/kdeplatformtheme.cpp
-index 24ac7e7..18b3f6f 100644
---- a/src/platformtheme/kdeplatformtheme.cpp
-+++ b/src/platformtheme/kdeplatformtheme.cpp
-@@ -257,6 +257,8 @@ QList<QKeySequence> KdePlatformTheme::keyBindings(QKeySequence::StandardKey key)
- return KStandardShortcut::shortcut(KStandardShortcut::TabNext);
- case QKeySequence::PreviousChild:
- return KStandardShortcut::shortcut(KStandardShortcut::TabPrev);
-+ case QKeySequence::Delete:
-+ return KStandardShortcut::shortcut(KStandardShortcut::MoveToTrash);
- default:
- return QPlatformTheme::keyBindings(key);
- }
---
-GitLab
-
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.19.5-r1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.19.5-r1.ebuild
deleted file mode 100644
index ad56b885e448..000000000000
--- a/kde-plasma/plasma-integration/plasma-integration-5.19.5-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-KFMIN=5.71.0
-PVCUT=$(ver_cut 1-3)
-QTMIN=5.14.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
-
-LICENSE="LGPL-2+"
-SLOT="5"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE=""
-
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5=[dbus]
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kjobwidgets-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/kwayland-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-plasma/breeze-${PVCUT}:5
- x11-libs/libXcursor
- x11-libs/libxcb
-"
-RDEPEND="${DEPEND}
- media-fonts/hack
- media-fonts/noto
-"
-
-# requires running kde environment
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}"/${P}-use-standard-kde-shortcut-for-move-to-trash.patch )