summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild')
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild b/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild
new file mode 100644
index 000000000000..52c95616114b
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ppc x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_prepare() {
+ #bug 380043
+ epatch "${FILESDIR}"/${P}-logout.patch
+
+ # Rerun autotools
+ einfo "Regenerating autotools files..."
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ # install session file
+ insinto /etc/X11/Sessions/
+ doins ${FILESDIR}/lxde
+ fperms 755 /etc/X11/Sessions/lxde
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}