summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild')
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild
new file mode 100644
index 000000000000..de85f45f010b
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/libqtxdg-3.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ !lxqt-base/lxqt-common
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.5.0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}