summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/aewan/aewan-1.0.01-r1.ebuild')
-rw-r--r--media-gfx/aewan/aewan-1.0.01-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/aewan/aewan-1.0.01-r1.ebuild b/media-gfx/aewan/aewan-1.0.01-r1.ebuild
new file mode 100644
index 000000000000..7fdd8084cb70
--- /dev/null
+++ b/media-gfx/aewan/aewan-1.0.01-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A curses-based ascii-art editor"
+HOMEPAGE="http://aewan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DOCS=( CHANGELOG README TODO )
+
+DEPEND="sys-libs/zlib
+ >=sys-libs/ncurses-5.0"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-debug_aewl-warnings.patch" \
+ "${FILESDIR}/${P}-tinfo.patch"
+ eautoreconf
+}