summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/asymptote')
-rw-r--r--media-gfx/asymptote/Manifest2
-rw-r--r--media-gfx/asymptote/asymptote-2.21.ebuild205
-rw-r--r--media-gfx/asymptote/asymptote-2.32.ebuild214
-rw-r--r--media-gfx/asymptote/files/64asymptote-gentoo.el9
-rw-r--r--media-gfx/asymptote/files/asy-ftd.vim2
-rw-r--r--media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-2.21-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch22
-rw-r--r--media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-2.27-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch23
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch24
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch23
-rw-r--r--media-gfx/asymptote/metadata.xml32
16 files changed, 691 insertions, 0 deletions
diff --git a/media-gfx/asymptote/Manifest b/media-gfx/asymptote/Manifest
new file mode 100644
index 000000000000..8453a4e46b51
--- /dev/null
+++ b/media-gfx/asymptote/Manifest
@@ -0,0 +1,2 @@
+DIST asymptote-2.21.src.tgz 1797507 SHA256 5fe6cfa880a9dba36105d45e5c2bcd0491240da760d455997656dd6e3b90931e SHA512 10341674f0b88611a341d2cb8abd1dfaec1d2711111bb66fb3cd00442427b432107c6c6deeec548b4c7cf114b77a764f0efe627bf421f990e64626d3bb60a91a WHIRLPOOL d30d88eac92e1e4ea411a54e0bd0149d5146db484113cbbc990cbb5250ef46fac804668929f652fddfc87a094f150692abb5f0f2b2719801fe424eb6e31f4d77
+DIST asymptote-2.32.src.tgz 1794495 SHA256 2035035e02774598312d5588da2685d20fb85a378ea2bbe48b825c5442b18fa5 SHA512 a0663f1768cb4340bb6e9224d4fbc6e2f8b41501b1f59793d84db2e0f99b9ff071d3dd8fa5c4715c1874f8ef1af713a54b27de37ff40d8ca042f0f48579a57f9 WHIRLPOOL 38a8aaa581acb07bcc7ac0c802222501acf77abaf609d5ae758d9b5668ac6b8b1343640259cc3948e62a39862404709ddb64b4bbd11bcf20dbb7ce29d4fc25d1
diff --git a/media-gfx/asymptote/asymptote-2.21.ebuild b/media-gfx/asymptote/asymptote-2.21.ebuild
new file mode 100644
index 000000000000..eb0317753505
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-2.21.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils autotools elisp-common latex-package multilib python
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex offscreen +opengl python sigsegv svg vim-syntax X"
+
+REQUIRED_USE="offscreen? ( opengl )"
+
+RDEPEND="
+ >=sys-libs/readline-4.3-r5:0
+ >=sys-libs/ncurses-5.4-r5
+ imagemagick? ( media-gfx/imagemagick[png] )
+ opengl? ( >=media-libs/mesa-8 )
+ offscreen? ( media-libs/mesa[osmesa] )
+ svg? ( app-text/dvisvgm )
+ sigsegv? ( dev-libs/libsigsegv )
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0[cxx,threads] )
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ gsl? ( sci-libs/gsl )
+ X? ( x11-misc/xdg-utils dev-lang/python dev-python/imaging[tk] )
+ latex? ( virtual/latex-base dev-texlive/texlive-latexextra )
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ doc? ( dev-lang/perl virtual/texi2dvi virtual/latex-base media-gfx/imagemagick[png] )"
+
+TEXMF=/usr/share/texmf-site
+
+src_prepare() {
+ # Fixing sigsegv enabling
+ epatch "${FILESDIR}/${P}-configure-ac.patch"
+ einfo "Patching configure.ac"
+ sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ -i configure.ac \
+ || die "sed configure.ac failed"
+
+ # Changing pdf, ps, image viewers to xdg-open
+ epatch "${FILESDIR}/${P}-xdg-utils.patch"
+
+ # Bug #322473
+ epatch "${FILESDIR}/${P}-info.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # for the CPPFLAGS see
+ # http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ econf \
+ CPPFLAGS=-DHAVE_SYS_TYPES_H \
+ CFLAGS="${CXXFLAGS}" \
+ --disable-gc-debug \
+ $(use_enable boehm-gc gc system) \
+ $(use_enable fftw) \
+ $(use_enable gsl) \
+ $(use_enable opengl gl) \
+ $(use_enable offscreen) \
+ $(use_with sigsegv)
+}
+
+src_compile() {
+ emake
+
+ cd doc || die
+ emake asy.1
+ if use doc; then
+ # info
+ einfo "Making info"
+ emake ${PN}.info
+ cd FAQ || die
+ emake
+ cd .. || die
+ # pdf
+ einfo "Making pdf docs"
+ export VARTEXFONTS="${T}"/fonts
+ # see bug #260606
+ emake -j1 asymptote.pdf
+ emake CAD.pdf
+ fi
+ cd .. || die
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile base/*.el
+ fi
+}
+
+src_install() {
+ # the program
+ dobin asy
+
+ # .asy files
+ insinto /usr/share/${PN}
+ doins base/*.asy
+
+ # documentation
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+ doman doc/asy.1
+
+ # X GUI
+ if use X; then
+ exeinto /usr/share/${PN}/GUI
+ doexe GUI/xasy.py
+ rm GUI/xasy.py || die
+ insinto /usr/share/${PN}/GUI
+ doins GUI/*.py
+ dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
+ doman doc/xasy.1x
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins \
+ examples/*.asy \
+ examples/*.eps \
+ doc/*.asy \
+ doc/*.csv \
+ doc/*.dat \
+ doc/extra/*.asy
+ use X && doins GUI/*.asy
+
+ insinto /usr/share/${PN}/examples/animations
+ doins examples/animations/*.asy
+ fi
+
+ # LaTeX style
+ if use latex; then
+ cd doc || die
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins ${PN}.sty asycolors.sty
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins latexusage.tex
+ fi
+ cd .. || die
+ fi
+
+ # asymptote.py
+ if use python; then
+ python_install() {
+ insinto "$(python_get_sitedir)"
+ doins base/${PN}.py
+ }
+ python_execute_function python_install
+ fi
+
+ # emacs mode
+ if use emacs; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ fi
+
+ # vim syntax
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/asy-ftd.vim
+ fi
+
+ # extra documentation
+ if use doc; then
+ cd doc || die
+ doinfo ${PN}.info*
+ cd FAQ || die
+ dodoc asy-faq.ascii
+ doinfo asy-faq.info
+ insinto /usr/share/doc/${PF}/html/FAQ
+ doins asy-faq.html/*
+ cd .. || die
+ insinto /usr/share/doc/${PF}
+ doins ${PN}.pdf CAD.pdf
+ fi
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}.py
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+}
diff --git a/media-gfx/asymptote/asymptote-2.32.ebuild b/media-gfx/asymptote/asymptote-2.32.ebuild
new file mode 100644
index 000000000000..41b0a1f8f1cc
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-2.32.ebuild
@@ -0,0 +1,214 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools elisp-common eutils latex-package multilib python-single-r1
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex offscreen +opengl python sigsegv svg vim-syntax X"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ offscreen? ( opengl )"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.4-r5
+ >=sys-libs/readline-4.3-r5:0=
+ imagemagick? ( media-gfx/imagemagick[png] )
+ opengl? ( >=media-libs/mesa-8 )
+ offscreen? ( media-libs/mesa[osmesa] )
+ svg? ( app-text/dvisvgm )
+ sigsegv? ( dev-libs/libsigsegv )
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0[cxx,threads] )
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ gsl? ( sci-libs/gsl )
+ python? ( ${PYTHON_DEPS} )
+ X? (
+ ${PYTHON_DEPS}
+ x11-misc/xdg-utils
+ virtual/python-imaging[tk,${PYTHON_USEDEP}]
+ )
+ latex? (
+ virtual/latex-base
+ >=dev-texlive/texlive-latexextra-2013
+ )
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-lang/perl
+ media-gfx/imagemagick[png]
+ virtual/texi2dvi
+ virtual/latex-base
+ )"
+
+TEXMF=/usr/share/texmf-site
+
+pkg_setup() {
+ (use python || use X) && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fixing sigsegv enabling
+ epatch "${FILESDIR}/${P}-configure-ac.patch"
+ einfo "Patching configure.ac"
+ sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ -i configure.ac \
+ || die "sed configure.ac failed"
+
+ # Changing pdf, ps, image viewers to xdg-open
+ epatch "${FILESDIR}/${P}-xdg-utils.patch"
+
+ # Bug #322473
+ epatch "${FILESDIR}/${P}-info.patch"
+
+ # Bug #528632 - fix from https://www.archlinux.org/packages/extra/x86_64/asymptote/
+ epatch "${FILESDIR}/${P}-ghostscript-9.15.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # for the CPPFLAGS see
+ # http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ econf \
+ CPPFLAGS=-DHAVE_SYS_TYPES_H \
+ CFLAGS="${CXXFLAGS}" \
+ --disable-gc-debug \
+ $(use_enable boehm-gc gc system) \
+ $(use_enable fftw) \
+ $(use_enable gsl) \
+ $(use_enable opengl gl) \
+ $(use_enable offscreen) \
+ $(use_with sigsegv)
+}
+
+src_compile() {
+ default
+
+ cd doc || die
+ emake asy.1
+ if use doc; then
+ # info
+ einfo "Making info"
+ emake ${PN}.info
+ cd FAQ || die
+ emake
+ cd .. || die
+ # pdf
+ einfo "Making pdf docs"
+ export VARTEXFONTS="${T}"/fonts
+ # see bug #260606
+ emake -j1 asymptote.pdf
+ emake CAD.pdf
+ fi
+ cd .. || die
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile base/*.el
+ fi
+}
+
+src_install() {
+ # the program
+ dobin asy
+
+ # .asy files
+ insinto /usr/share/${PN}
+ doins base/*.asy
+
+ # documentation
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+ doman doc/asy.1
+
+ # X GUI
+ if use X; then
+ python_scriptinto /usr/share/${PN}/GUI
+ python_doscript GUI/*.py
+ dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
+ doman doc/xasy.1x
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins \
+ examples/*.asy \
+ examples/*.eps \
+ doc/*.asy \
+ doc/*.csv \
+ doc/*.dat \
+ doc/extra/*.asy
+ use X && doins GUI/*.asy
+
+ insinto /usr/share/${PN}/examples/animations
+ doins examples/animations/*.asy
+ fi
+
+ # LaTeX style
+ if use latex; then
+ cd doc || die
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins ${PN}.sty asycolors.sty
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins latexusage.tex
+ fi
+ cd .. || die
+ fi
+
+ # asymptote.py
+ use python && python_domodule base/${PN}.py
+
+ # emacs mode
+ if use emacs; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ fi
+
+ # vim syntax
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/asy-ftd.vim
+ fi
+
+ # extra documentation
+ if use doc; then
+ cd doc || die
+ doinfo ${PN}.info*
+ cd FAQ || die
+ dodoc asy-faq.ascii
+ doinfo asy-faq.info
+ insinto /usr/share/doc/${PF}/html/FAQ
+ doins asy-faq.html/*
+ cd .. || die
+ insinto /usr/share/doc/${PF}
+ doins ${PN}.pdf CAD.pdf
+ fi
+}
+
+pkg_postinst() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+}
+
+pkg_postrm() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+}
diff --git a/media-gfx/asymptote/files/64asymptote-gentoo.el b/media-gfx/asymptote/files/64asymptote-gentoo.el
new file mode 100644
index 000000000000..57cd48d04a64
--- /dev/null
+++ b/media-gfx/asymptote/files/64asymptote-gentoo.el
@@ -0,0 +1,9 @@
+
+;; site-init for media-gfx/asymptote
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'asy-mode "asy-mode" "Asymptote major mode." t)
+(autoload 'lasy-mode "asy-mode" "Hybrid Asymptote/Latex major mode." t)
+(autoload 'asy-insinuate-latex "asy-mode" "Asymptote insinuate LaTeX." t)
+(add-to-list 'auto-mode-alist '("\\.asy$" . asy-mode))
diff --git a/media-gfx/asymptote/files/asy-ftd.vim b/media-gfx/asymptote/files/asy-ftd.vim
new file mode 100644
index 000000000000..0f5e3957900a
--- /dev/null
+++ b/media-gfx/asymptote/files/asy-ftd.vim
@@ -0,0 +1,2 @@
+au BufNewFile,BufRead *.asy setf asy
+filetype plugin on
diff --git a/media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch b/media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch
new file mode 100644
index 000000000000..e65c18dc455b
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.21-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-2.21/configure.ac
+===================================================================
+--- asymptote-2.21.orig/configure.ac
++++ asymptote-2.21/configure.ac
+@@ -154,7 +154,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -227,7 +227,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz on your system ***]))
+ AX_PTHREAD
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-2.21-info.patch b/media-gfx/asymptote/files/asymptote-2.21-info.patch
new file mode 100644
index 000000000000..cb5f43671add
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.21-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.21/doc/asymptote.texi
+===================================================================
+--- asymptote-2.21.orig/doc/asymptote.texi
++++ asymptote-2.21/doc/asymptote.texi
+@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch
new file mode 100644
index 000000000000..5fb54d80f785
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.21-xdg-utils.patch
@@ -0,0 +1,22 @@
+Index: asymptote-2.21/settings.cc
+===================================================================
+--- asymptote-2.21.orig/settings.cc
++++ asymptote-2.21/settings.cc
+@@ -90,14 +90,14 @@ bool msdos=false;
+ string HOME="HOME";
+ string docdir=ASYMPTOTE_DOCDIR;
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";
diff --git a/media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch b/media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch
new file mode 100644
index 000000000000..df02ad92fcb3
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.27-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-2.27/configure.ac
+===================================================================
+--- asymptote-2.27.orig/configure.ac
++++ asymptote-2.27/configure.ac
+@@ -155,7 +155,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -229,7 +229,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz or zlib-devel on your system ***]))
+ AX_PTHREAD
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-2.27-info.patch b/media-gfx/asymptote/files/asymptote-2.27-info.patch
new file mode 100644
index 000000000000..a64c8eb467ac
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.27-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.27/doc/asymptote.texi
+===================================================================
+--- asymptote-2.27.orig/doc/asymptote.texi
++++ asymptote-2.27/doc/asymptote.texi
+@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch
new file mode 100644
index 000000000000..1be4a4b89435
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.27-xdg-utils.patch
@@ -0,0 +1,23 @@
+Index: asymptote-2.27/settings.cc
+===================================================================
+--- asymptote-2.27.orig/settings.cc
++++ asymptote-2.27/settings.cc
+@@ -90,15 +90,15 @@ bool msdos=false;
+ string HOME="HOME";
+ string docdir=ASYMPTOTE_DOCDIR;
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+ string defaultGhostscriptLibrary="/usr/lib/libgs.so";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";
diff --git a/media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch b/media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch
new file mode 100644
index 000000000000..597e915539be
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-2.32/configure.ac
+===================================================================
+--- asymptote-2.32.orig/configure.ac
++++ asymptote-2.32/configure.ac
+@@ -158,7 +158,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -232,7 +232,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz or zlib-devel on your system ***]))
+ AX_PTHREAD
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch b/media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch
new file mode 100644
index 000000000000..aa826c5c251f
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-ghostscript-9.15.patch
@@ -0,0 +1,24 @@
+diff -r -U2 asymptote-2.32.orig/runlabel.in asymptote-2.32/runlabel.in
+--- asymptote-2.32.orig/runlabel.in 2014-05-22 23:11:47.000000000 +0700
++++ asymptote-2.32/runlabel.in 2015-01-11 21:41:30.268889133 +0600
+@@ -112,5 +112,5 @@
+ const string null="/dev/null";
+ #endif
+- cmd.push_back("-sDEVICE=epswrite");
++ cmd.push_back("-sDEVICE=eps2write");
+ cmd.push_back("-sOutputFile="+null);
+ cmd.push_back(stripDir(psname));
+@@ -310,5 +310,5 @@
+ cmd.push_back("-dBATCH");
+ if(safe) cmd.push_back("-dSAFER");
+- cmd.push_back("-sDEVICE=epswrite");
++ cmd.push_back("-sDEVICE=eps2write");
+ cmd.push_back("-sOutputFile=-");
+ cmd.push_back(pdfname);
+@@ -399,5 +399,5 @@
+ cmd2.push_back("-P");
+ if(safe) cmd2.push_back("-dSAFER");
+- cmd2.push_back("-sDEVICE=epswrite");
++ cmd2.push_back("-sDEVICE=eps2write");
+ cmd2.push_back("-sOutputFile=-");
+ cmd2.push_back("-");
diff --git a/media-gfx/asymptote/files/asymptote-2.32-info.patch b/media-gfx/asymptote/files/asymptote-2.32-info.patch
new file mode 100644
index 000000000000..8a1e3f464231
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.32/doc/asymptote.texi
+===================================================================
+--- asymptote-2.32.orig/doc/asymptote.texi
++++ asymptote-2.32/doc/asymptote.texi
+@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch
new file mode 100644
index 000000000000..2ac59e59f058
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.32-xdg-utils.patch
@@ -0,0 +1,23 @@
+Index: asymptote-2.32/settings.cc
+===================================================================
+--- asymptote-2.32.orig/settings.cc
++++ asymptote-2.32/settings.cc
+@@ -90,15 +90,15 @@ bool msdos=false;
+ string HOME="HOME";
+ string docdir=ASYMPTOTE_DOCDIR;
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+ string defaultGhostscriptLibrary="/usr/lib/libgs.so";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";
diff --git a/media-gfx/asymptote/metadata.xml b/media-gfx/asymptote/metadata.xml
new file mode 100644
index 000000000000..83bd6f53fce8
--- /dev/null
+++ b/media-gfx/asymptote/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription lang="en">
+ Asymptote is a powerful descriptive vector graphics language that
+ provides a natural coordinate-based framework for technical drawing.
+ Labels and equations are typeset with LaTeX, for high-quality PostScript
+ output.
+
+ A major advantage of Asymptote over other graphics packages is that it
+ is a programming language, as opposed to just a graphics program.
+ </longdescription>
+ <use>
+ <flag name="boehm-gc">
+ Enables using the Boehm-Demers-Weiser conservative garbage collector
+ </flag>
+ <flag name="sigsegv">
+ Enables using <pkg>dev-libs/libsigsegv</pkg>
+ </flag>
+ <flag name="offscreen">
+ Enables off-screen rendering
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">asymptote</remote-id>
+ </upstream>
+</pkgmetadata>