summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fbida/files/fbida-2.09-make.patch')
-rw-r--r--media-gfx/fbida/files/fbida-2.09-make.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/fbida/files/fbida-2.09-make.patch b/media-gfx/fbida/files/fbida-2.09-make.patch
new file mode 100644
index 000000000000..61c19a3cfc72
--- /dev/null
+++ b/media-gfx/fbida/files/fbida-2.09-make.patch
@@ -0,0 +1,36 @@
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -30,8 +30,8 @@
+
+ ac_jpeg_ver = $(shell \
+ $(call ac_init,for libjpeg version);\
+- $(call ac_s_cmd,echo -e '\#include <jpeglib.h>\nJPEG_LIB_VERSION' \
+- | cpp | tail -n 1);\
++ $(call ac_s_cmd,printf '\#include <jpeglib.h>\nJPEG_LIB_VERSION' \
++ | $(CPP) | tail -n 1);\
+ $(call ac_fini))
+
+ define make-config
+--- a/mk/Autoconf.mk
++++ b/mk/Autoconf.mk
+@@ -24,7 +24,7 @@ ifneq ($(verbose),no)
+ ac_fini = echo "... result is $${rc}" >&2; echo >&2; echo "$${rc}"
+ else
+ # normal
+- ac_init = echo -n "checking $(1) ... " >&2; rc=no
++ ac_init = printf '%s' "checking $(1) ... " >&2; rc=no
+ ac_b_cmd = $(1) >/dev/null 2>&1 && rc=yes
+ ac_s_cmd = rc=`$(1) 2>/dev/null`
+ ac_fini = echo "$${rc}" >&2; echo "$${rc}"
+@@ -162,7 +162,7 @@ config: Make.config
+ @true
+
+ Make.config: $(srcdir)/GNUmakefile
+- @echo -e "$(make-config-q)" > $@
++ @printf '%b' "$(make-config-q)" > $@
+ @echo
+ @echo "Make.config written, edit if needed"
+ @echo
+--
+1.7.5.3
+