summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gliv/gliv-1.9.7.ebuild')
-rw-r--r--media-gfx/gliv/gliv-1.9.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/gliv/gliv-1.9.7.ebuild b/media-gfx/gliv/gliv-1.9.7.ebuild
new file mode 100644
index 000000000000..582a0329952e
--- /dev/null
+++ b/media-gfx/gliv/gliv-1.9.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="An image viewer that uses OpenGL"
+HOMEPAGE="http://guichaz.free.fr/gliv/"
+SRC_URI="http://guichaz.free.fr/gliv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.6:2
+ virtual/opengl
+ >x11-libs/gtkglext-1.0.6
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/bison-1.875
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ # Fix build with gettext-0.19, bug #512624
+ # using gettextize no-interactive example from dev-util/bless package
+ if use nls; then
+ cp $(type -p gettextize) "${T}"/
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog --intl > /dev/null
+ fi
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}/${P}-destdir.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}