summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jp2a/jp2a-1.0.6-r1.ebuild')
-rw-r--r--media-gfx/jp2a/jp2a-1.0.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/jp2a/jp2a-1.0.6-r1.ebuild b/media-gfx/jp2a/jp2a-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..0acbcbd4d344
--- /dev/null
+++ b/media-gfx/jp2a/jp2a-1.0.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="JPEG image to ASCII art converter"
+HOMEPAGE="http://csl.sublevel3.org/jp2a/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 ~sparc x86 ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="curl"
+
+RDEPEND="sys-libs/ncurses
+ virtual/jpeg
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable curl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml man/jp2a.html
+}