summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/openexr_viewers/files')
-rw-r--r--media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc43.patch55
-rw-r--r--media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc44.patch37
-rw-r--r--media-gfx/openexr_viewers/files/openexr_viewers-1.0.2-nvidia-automagic.patch16
-rw-r--r--media-gfx/openexr_viewers/files/openexr_viewers-2.0.0-nvidia-automagic.patch14
4 files changed, 122 insertions, 0 deletions
diff --git a/media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc43.patch b/media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc43.patch
new file mode 100644
index 000000000000..3630efc6f7a2
--- /dev/null
+++ b/media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc43.patch
@@ -0,0 +1,55 @@
+diff -up openexr_viewers-1.0.1/exrdisplay/applyCtl.h.gcc43 openexr_viewers-1.0.1/exrdisplay/applyCtl.h
+--- openexr_viewers-1.0.1/exrdisplay/applyCtl.h.gcc43 2006-12-09 01:14:07.000000000 +0100
++++ openexr_viewers-1.0.1/exrdisplay/applyCtl.h 2008-01-10 02:07:14.000000000 +0100
+@@ -49,6 +49,7 @@
+ #include <ImfArray.h>
+ #include <ImfHeader.h>
+ #include <vector>
++#include <cstdlib>
+
+ //
+ // Apply a series of CTL transforms to the raw pixel data from an image file
+diff -up openexr_viewers-1.0.1/configure.ac.gcc43 openexr_viewers-1.0.1/configure.ac
+--- openexr_viewers-1.0.1/configure.ac.gcc43 2007-10-10 00:20:51.000000000 +0200
++++ openexr_viewers-1.0.1/configure.ac 2008-01-10 02:07:14.000000000 +0100
+@@ -126,6 +126,7 @@ AM_COMPILELINKRUN(
+ #include <ImfFrameBuffer.h>
+ #include <ImathBox.h>
+ #include <vector>
++#include <cstdlib>
+ using namespace Ctl;
+ using namespace Imf;
+ using namespace Imath;
+diff -up openexr_viewers-1.0.1/configure.gcc43 openexr_viewers-1.0.1/configure
+--- openexr_viewers-1.0.1/configure.gcc43 2007-10-10 00:21:01.000000000 +0200
++++ openexr_viewers-1.0.1/configure 2008-01-10 02:07:14.000000000 +0100
+@@ -20869,6 +20869,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <ImfFrameBuffer.h>
+ #include <ImathBox.h>
+ #include <vector>
++#include <cstdlib>
+ using namespace Ctl;
+ using namespace Imf;
+ using namespace Imath;
+diff -up openexr_viewers-1.0.1/playexr/ctlToLut.h.gcc43 openexr_viewers-1.0.1/playexr/ctlToLut.h
+--- openexr_viewers-1.0.1/playexr/ctlToLut.h.gcc43 2008-01-10 03:09:55.000000000 +0100
++++ openexr_viewers-1.0.1/playexr/ctlToLut.h 2008-01-10 03:11:18.000000000 +0100
+@@ -88,6 +88,7 @@
+ #include <string>
+ #include <vector>
+ #include <half.h>
++#include <cstdlib>
+
+
+ void
+diff -up openexr_viewers-1.0.1/playexr/main.cpp.gcc43 openexr_viewers-1.0.1/playexr/main.cpp
+--- openexr_viewers-1.0.1/playexr/main.cpp.gcc43 2008-01-10 03:05:03.000000000 +0100
++++ openexr_viewers-1.0.1/playexr/main.cpp 2008-01-10 03:05:48.000000000 +0100
+@@ -48,6 +48,7 @@
+ #include <vector>
+ #include <string>
+ #include <stdlib.h>
++#include <cstring>
+
+ using namespace std;
+
diff --git a/media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc44.patch b/media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc44.patch
new file mode 100644
index 000000000000..4ab58548d71a
--- /dev/null
+++ b/media-gfx/openexr_viewers/files/openexr_viewers-1.0.1-gcc44.patch
@@ -0,0 +1,37 @@
+diff -ur openexr_viewers-1.0.1.orig/exrdisplay/applyCtl.cpp openexr_viewers-1.0.1/exrdisplay/applyCtl.cpp
+--- playexr/ctlToLut.cpp.orig 2009-12-14 09:07:00.863493115 -0800
++++ playexr/ctlToLut.cpp 2009-12-14 09:08:16.721186947 -0800
+@@ -49,6 +49,7 @@
+ #include <ImfFrameBuffer.h>
+ #include <cassert>
+ #include <iostream>
++ #include <cstdio>
+
+ using namespace std;
+ using namespace Ctl;
+@@ -61,6 +62,7 @@
+ #include <ImfHeader.h>
+ #include <cassert>
+ #include <iostream>
++ #include <cstdio>
+
+ using namespace std;
+ using namespace Imf;
+--- exrdisplay/applyCtl.cpp.orig 2009-12-14 09:11:44.950334079 -0800
++++ exrdisplay/applyCtl.cpp 2009-12-14 09:11:59.900332294 -0800
+@@ -49,6 +49,7 @@
+ #include <ImfFrameBuffer.h>
+ #include <cassert>
+ #include <iostream>
++ #include <cstdio>
+
+ using namespace std;
+ using namespace Ctl;
+@@ -61,6 +62,7 @@
+ #include <ImfHeader.h>
+ #include <cassert>
+ #include <iostream>
++ #include <cstdio>
+
+ using namespace std;
+ using namespace Imf;
diff --git a/media-gfx/openexr_viewers/files/openexr_viewers-1.0.2-nvidia-automagic.patch b/media-gfx/openexr_viewers/files/openexr_viewers-1.0.2-nvidia-automagic.patch
new file mode 100644
index 000000000000..e39a0c1da789
--- /dev/null
+++ b/media-gfx/openexr_viewers/files/openexr_viewers-1.0.2-nvidia-automagic.patch
@@ -0,0 +1,16 @@
+--- configure.ac
++++ configure.ac
+@@ -188,8 +188,11 @@
+
+ dnl
+ dnl check for Cg
+-dnlCG_LD
+-if test "${have_fltk}" = yes; then
++dnl CG_LD
++AC_ARG_ENABLE(nvidia, AC_HELP_STRING([--enable-nvidia],
++ [enable nvidia cg support [[default=check]]]), [want_nvidia="${enableval}"], [want_nvidia=yes])
++
++if test "${have_fltk}" = yes -a "${want_nvidia}" != "no"; then
+ AM_PATH_CG(have_cg=yes, have_cg=no)
+ if test "${have_cg}" = yes; then
+ AC_DEFINE(HAVE_FRAGMENT_SHADERS)
diff --git a/media-gfx/openexr_viewers/files/openexr_viewers-2.0.0-nvidia-automagic.patch b/media-gfx/openexr_viewers/files/openexr_viewers-2.0.0-nvidia-automagic.patch
new file mode 100644
index 000000000000..1ea9f869a671
--- /dev/null
+++ b/media-gfx/openexr_viewers/files/openexr_viewers-2.0.0-nvidia-automagic.patch
@@ -0,0 +1,14 @@
+--- configure.ac
++++ configure.ac
+@@ -192,7 +192,10 @@
+ dnl
+ dnl check for Cg
+ dnl
+-if test "${have_fltk}" = yes; then
++AC_ARG_ENABLE(cg, AC_HELP_STRING([--enable-cg],
++ [enable nvidia cg support [[default=check]]]), [want_cg="${enableval}"], [want_cg=yes])
++
++if test "${have_fltk}" = yes -a "${want_cg}" != "no"; then
+ AM_PATH_CG(have_cg=yes, have_cg=no)
+ if test "${have_cg}" = yes; then
+ AC_DEFINE(HAVE_FRAGMENT_SHADERS)