summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/splash-themes-gentoo')
-rw-r--r--media-gfx/splash-themes-gentoo/Manifest4
-rw-r--r--media-gfx/splash-themes-gentoo/metadata.xml7
-rw-r--r--media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild41
-rw-r--r--media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r2.ebuild48
4 files changed, 100 insertions, 0 deletions
diff --git a/media-gfx/splash-themes-gentoo/Manifest b/media-gfx/splash-themes-gentoo/Manifest
new file mode 100644
index 000000000000..35553c0b233d
--- /dev/null
+++ b/media-gfx/splash-themes-gentoo/Manifest
@@ -0,0 +1,4 @@
+DIST fbsplash-theme-emerge-world-1.0.tar.bz2 3963650 SHA256 a00ee0364842b276389eb09c95fa3ee16ad3fa15017998fe6765d45167015d7d SHA512 a77f0a97cc97c60159dfa3f445de827c26c261d7194a7716277a8ae5c197ffd31cc7c703aec053fc59fad5e855e049d65ad3eb313789d7e1524c574fedc2ec7b WHIRLPOOL 5f3f0ce84cc959632110507ce90b329a9c0ac23ec8b93d63b4d8155b7aa3e166020e526609072844b1a8b9005f7bf6fa22cfde08fb492e7b4c6222060280ad01
+DIST fbsplash-theme-emergence-r2.tar.bz2 4794297 SHA256 77eda040aa858b19c822549bb1478dbb66a5e68f5ce3dade727ef36ae9121d92 SHA512 eefb2c1e09e9efbe6f574d007633a85d83227a526711845f5ede36b4664d781c2de05f3a79ba8d710114dd98559328aaee816983a5dc486cce089e4afb0dd260 WHIRLPOOL 341d35ab37e2489620419c5c644891518c2a2b83422d40f0636190608fa25b3cb1ed2d2afc0ead333950c2bcf4eec3f237d6f9bb27ce00a4290abf2a83a15ac2
+DIST fbsplash-theme-gentoo-r2.tar.bz2 5605891 SHA256 30bc1e5a13d978c0c3ad4b9c25576897018053d3e9d573e7af0a8865bc2f3f82 SHA512 eb7b90f8e3821e76ca75706841cd6a170a3bcdc0bfff6e876eb5425f211e3501ad78479e7b8f232eb1e221dfacf450620ffd10191790173359ee053ab9843eea WHIRLPOOL eceaef29d6029199b987125237b4f93e335119228f92b1cd85955ca2b49e3fa2a5992c7f161be3428137f09d352354f25b2b92a5f3cf199985781590f0c30bc8
+DIST natural_gentoo-9.0-r2.tar.bz2 433306 SHA256 9f31569123854dbeff596e40edcdb88dcb953a90d936ff6c9e177cf52d3825a2 SHA512 ba24da013d2f9c63d7974d443c8529bdd10b552b02006ee107b0b4b1f1034c27448754f220ae153557058f1b359061036c83e687ead2a179392f9239f9fcf686 WHIRLPOOL 5b99a7a5ae4f54907bb2c21f47c0ac3986c38774a8ce11d0a632d6ce239aa1a7c4504a2fb1629cc844e16b8b147a133cc9e7cdbed9e311ab39f1a58cb2067990
diff --git a/media-gfx/splash-themes-gentoo/metadata.xml b/media-gfx/splash-themes-gentoo/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/media-gfx/splash-themes-gentoo/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild b/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild
new file mode 100644
index 000000000000..df633601bb74
--- /dev/null
+++ b/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="A collection of Gentoo themes for splashutils"
+HOMEPAGE="http://dev.gentoo.org/~spock/"
+SRC_URI="mirror://gentoo/fbsplash-theme-emergence-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-gentoo-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-emerge-world-1.0.tar.bz2
+ http://fbsplash.berlios.de/themes/repo/natural_gentoo-9.0-r2.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=media-gfx/splashutils-1.1.9.5[png]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ sed -i -e 's/natural-gentoo/natural_gentoo/g' natural_gentoo/*.cfg || die 'sed failed'
+}
+
+src_install() {
+ insinto /etc/splash
+ doins -r *
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "The upstream tarball for the 'Natural Gentoo' theme also contains a GRUB"
+ elog "splash image which is not installed by this ebuild. See:"
+ elog " http://www.kde-look.org/content/show.php?content=49074"
+ elog "if you are interested in this."
+ fi
+}
diff --git a/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r2.ebuild b/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r2.ebuild
new file mode 100644
index 000000000000..92fc8e78b933
--- /dev/null
+++ b/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="A collection of Gentoo themes for splashutils"
+HOMEPAGE="http://dev.gentoo.org/~spock/"
+SRC_URI="mirror://gentoo/fbsplash-theme-emergence-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-gentoo-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-emerge-world-1.0.tar.bz2
+ http://fbsplash.berlios.de/themes/repo/natural_gentoo-9.0-r2.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-gfx/splashutils-1.1.9.5[png]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ sed -i -e 's/natural-gentoo/natural_gentoo/g' natural_gentoo/*.cfg || die 'sed failed'
+}
+
+src_install() {
+ # They need to be executable, bug #470100
+ insinto /etc/splash
+ doins -r *
+
+ # They need to be executable, bug #470100
+ fperms +x /etc/splash/emerge-world/scripts/svc_started-pre
+ fperms +x /etc/splash/emerge-world/scripts/svc_start-pre
+ fperms +x /etc/splash/emerge-world/scripts/svc_stopped-pre
+ fperms +x /etc/splash/emerge-world/scripts/svc_stop-pre
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "The upstream tarball for the 'Natural Gentoo' theme also contains a GRUB"
+ elog "splash image which is not installed by this ebuild. See:"
+ elog " http://www.kde-look.org/content/show.php?content=49074"
+ elog "if you are interested in this."
+ fi
+}