summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/asymptote/Manifest1
-rw-r--r--media-gfx/asymptote/asymptote-2.60.ebuild211
-rw-r--r--media-gfx/asymptote/files/asymptote-2.60-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.60-xdg-utils.patch22
4 files changed, 247 insertions, 0 deletions
diff --git a/media-gfx/asymptote/Manifest b/media-gfx/asymptote/Manifest
index 641b83ceca7b..33ebd276ac97 100644
--- a/media-gfx/asymptote/Manifest
+++ b/media-gfx/asymptote/Manifest
@@ -2,3 +2,4 @@ DIST asymptote-2.41.src.tgz 3516426 BLAKE2B d4623609be58566e32de82c5c47f635ed737
DIST asymptote-2.47.src.tgz 3621676 BLAKE2B 575032093276b9df6b8d74897a4721dd0d5419b3380bce7962afc9dcdd20ec3bd47b5c4b882f2276a2ac4c0d99e657d7385122d7dc400efbfb52ceec753ee8f4 SHA512 9efc4a70e8d29d6d50ba49c54c48da38beb00f64e5b39f23dbaec5cb12b714e427473fdffbf71f2d636a007cbfc993fa3237a8beab01e3419c1da1287823c159
DIST asymptote-2.48.src.tgz 3729763 BLAKE2B 5820ddbbd27f6e7296501f50f25051d8417a0ab24d7c4c777013bf23601b5cbe34a69ba781e16e05141fda4e2e7a8bc527a41829f8d9e983aadc19bd05743122 SHA512 cd8b756185ae6627ea66bcaea224152f6644df633fe7ed40c1738f3b2ec31fbaa7ba97f2b1e290b073995779768ee3a264dd942f609b768cab7624d12807583d
DIST asymptote-2.49.src.tgz 3730453 BLAKE2B b52c2fbac5ea9c6046f2bd2990c7f3792823ae0ecd749c58990bcee898b8af7d26c4b457bee6aa15fb11e3c63a7cdc6d7e4976418ee96fc4470a17f3202d79cd SHA512 08c20e45ab764281b480a97c5e2294cdfcc18b179cbdc85cf9956806b40fe305360d589077bd3ac429985503b0e7d17c889a37349d8c6fdf8ccbd8d822544226
+DIST asymptote-2.60.src.tgz 4650347 BLAKE2B d969e4716a2493ae926ea1f58d0b247986e49a6a1902fb94859a45177ece4f149f5875cf788eace1c27c968652c49b2ace7b98aba02380cf8e1e3d4231560476 SHA512 a0653b9647d8c2a77656ea82faf8b69d28a43cf5ac61cfa9c6c62e2c51b4939e83202b95056495d10bee86a81e48b765ed4604a4d882a47a36b1dd6d5f9ad96b
diff --git a/media-gfx/asymptote/asymptote-2.60.ebuild b/media-gfx/asymptote/asymptote-2.60.ebuild
new file mode 100644
index 000000000000..d424b071ff4c
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-2.60.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit autotools elisp-common latex-package multilib python-r1
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex offscreen +opengl python sigsegv svg test vim-syntax X"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ offscreen? ( opengl )
+ doc? ( boehm-gc )"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.4-r5:0=
+ >=sys-libs/readline-4.3-r5:0=
+ imagemagick? ( media-gfx/imagemagick[png] )
+ opengl? ( media-libs/mesa[X(+)] media-libs/freeglut media-libs/glew:0 media-libs/glm )
+ offscreen? ( media-libs/mesa[osmesa] )
+ svg? ( app-text/dvisvgm )
+ sigsegv? ( dev-libs/libsigsegv )
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0[cxx,threads] )
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ gsl? ( sci-libs/gsl )
+ python? ( ${PYTHON_DEPS} )
+ X? (
+ ${PYTHON_DEPS}
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,svg]
+ dev-python/numpy
+ dev-python/pycson
+ >=gnome-base/librsvg-2.40
+ )
+ latex? (
+ virtual/latex-base
+ >=dev-texlive/texlive-latexextra-2013
+ )
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-lang/perl
+ media-gfx/imagemagick[png]
+ virtual/texi2dvi
+ virtual/latex-base
+ app-text/ghostscript-gpl )
+ test? ( app-text/ghostscript-gpl )"
+
+TEXMF=/usr/share/texmf-site
+
+PATCHES=(
+ # Changing pdf, ps, image viewers to xdg-open
+ "${FILESDIR}/${P}-xdg-utils.patch"
+
+ # Bug #322473
+ "${FILESDIR}/${P}-info.patch"
+)
+
+src_prepare() {
+ sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ -i configure.ac \
+ || die "sed configure.ac failed"
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # for the CPPFLAGS see
+ # https://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ econf \
+ CPPFLAGS=-DHAVE_SYS_TYPES_H \
+ CFLAGS="${CXXFLAGS}" \
+ --disable-gc-debug \
+ $(use_enable boehm-gc gc system) \
+ $(use_enable fftw) \
+ $(use_enable gsl) \
+ $(use_enable opengl gl) \
+ $(use_enable offscreen) \
+ $(use_enable sigsegv)
+}
+
+src_compile() {
+ default
+
+ cd doc || die
+ emake asy.1
+ if use doc; then
+ # info
+ einfo "Making info"
+ emake ${PN}.info
+ cd FAQ || die
+ emake
+ cd .. || die
+ # pdf
+ einfo "Making pdf docs"
+ export VARTEXFONTS="${T}"/fonts
+ # see bug #260606
+ emake -j1 asymptote.pdf
+ emake CAD.pdf
+ fi
+ cd .. || die
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile base/*.el
+ fi
+}
+
+src_install() {
+ # the program
+ dobin asy
+
+ # .asy files
+ insinto /usr/share/${PN}
+ doins base/*.asy
+
+ # documentation
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+ doman doc/asy.1
+
+ # X GUI
+ if use X; then
+ insinto /usr/share/${PN}
+ doins -r GUI
+ chmod +x "${D}"usr/share/${PN}/GUI/xasy.py
+ dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
+ doman doc/xasy.1x
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins \
+ examples/*.asy \
+ examples/*.eps \
+ doc/*.asy \
+ doc/*.csv \
+ doc/*.dat \
+ doc/extra/*.asy
+ insinto /usr/share/${PN}/examples/animations
+ doins examples/animations/*.asy
+ fi
+
+ # LaTeX style
+ if use latex; then
+ cd doc || die
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins ${PN}.sty asycolors.sty
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins latexusage.tex
+ fi
+ cd .. || die
+ fi
+
+ # asymptote.py
+ if use python; then
+ python_foreach_impl python_domodule base/${PN}.py
+ fi
+
+ # emacs mode
+ if use emacs; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ fi
+
+ # vim syntax
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/asy-ftd.vim
+ fi
+
+ # extra documentation
+ if use doc; then
+ cd doc || die
+ doinfo ${PN}.info*
+ cd FAQ || die
+ dodoc asy-faq.ascii
+ doinfo asy-faq.info
+ insinto /usr/share/doc/${PF}/html/FAQ
+ doins asy-faq.html/*
+ cd .. || die
+ insinto /usr/share/doc/${PF}
+ doins ${PN}.pdf CAD.pdf
+ fi
+}
+
+pkg_postinst() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+}
+
+pkg_postrm() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+}
diff --git a/media-gfx/asymptote/files/asymptote-2.60-info.patch b/media-gfx/asymptote/files/asymptote-2.60-info.patch
new file mode 100644
index 000000000000..f10aa2f3abc1
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.60-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.60/doc/asymptote.texi
+===================================================================
+--- asymptote-2.60.orig/doc/asymptote.texi
++++ asymptote-2.60/doc/asymptote.texi
+@@ -23,7 +23,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.60-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.60-xdg-utils.patch
new file mode 100644
index 000000000000..69eefaec963f
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.60-xdg-utils.patch
@@ -0,0 +1,22 @@
+Index: asymptote-2.60/settings.cc
+===================================================================
+--- asymptote-2.60.orig/settings.cc
++++ asymptote-2.60/settings.cc
+@@ -98,13 +98,13 @@ string defaultPSViewer="open";
+ string defaultPDFViewer="open";
+ string defaultHTMLViewer="open";
+ #else
+-string defaultPSViewer="gv";
+-string defaultPDFViewer="acroread";
+-string defaultHTMLViewer="google-chrome";
++string defaultPSViewer="xdg-open";
++string defaultPDFViewer="xdg-open";
++string defaultHTMLViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+ string defaultGhostscriptLibrary="";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";