summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/fdk-aac/fdk-aac-0.1.1.ebuild')
-rw-r--r--media-libs/fdk-aac/fdk-aac-0.1.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/fdk-aac/fdk-aac-0.1.1.ebuild b/media-libs/fdk-aac/fdk-aac-0.1.1.ebuild
new file mode 100644
index 000000000000..c015886e564c
--- /dev/null
+++ b/media-libs/fdk-aac/fdk-aac-0.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+fi
+
+inherit eutils multilib autotools ${SCM}
+
+DESCRIPTION="Fraunhofer AAC codec library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="FraunhoferFDK"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd ~x64-macos"
+IUSE="static-libs examples"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --disable-dependency-tracking \
+ $(use_enable examples example) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}