summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libafterimage')
-rw-r--r--media-libs/libafterimage/Manifest1
-rw-r--r--media-libs/libafterimage/files/libafterimage-config.patch15
-rw-r--r--media-libs/libafterimage/files/libafterimage-gif.patch18
-rw-r--r--media-libs/libafterimage/files/libafterimage-giflib42.patch19
-rw-r--r--media-libs/libafterimage/files/libafterimage-libpng15.patch31
-rw-r--r--media-libs/libafterimage/files/libafterimage-makefile.in.patch62
-rw-r--r--media-libs/libafterimage/libafterimage-1.20.ebuild95
-rw-r--r--media-libs/libafterimage/metadata.xml16
8 files changed, 257 insertions, 0 deletions
diff --git a/media-libs/libafterimage/Manifest b/media-libs/libafterimage/Manifest
new file mode 100644
index 000000000000..1017aee005eb
--- /dev/null
+++ b/media-libs/libafterimage/Manifest
@@ -0,0 +1 @@
+DIST libAfterImage-1.20.tar.bz2 1017055 SHA256 6e233253f4d1dd22dfce9f9a245cc036d814fc99ba7f6732f4e345de62cfe458 SHA512 4056c73d1ab401480803a3a932d647a66574df9f65efc0d30ba80800e1a3424b4fbfce8e9cdf82c4852862491d92cbb42392f8cce8d6ac21d3b49e4ffe1808c4 WHIRLPOOL 27ee6236ba9b84bb736c9caeabedf0f872fc4223d198f20c530d804d5ace1b91e2f5c26e2015a547899f1cea482a7ea5fcc91e84123ee7390eb38caa3460dd5b
diff --git a/media-libs/libafterimage/files/libafterimage-config.patch b/media-libs/libafterimage/files/libafterimage-config.patch
new file mode 100644
index 000000000000..d2ed9e032953
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-config.patch
@@ -0,0 +1,15 @@
+--- afterimage-config.in 2005-01-12 18:03:36.000000000 +0000
++++ afterimage-config.in.new 2006-10-15 14:16:12.000000000 +0100
+@@ -110,11 +110,7 @@
+ libs="-lAfterBase $libs"
+ fi
+ libs="-lAfterImage $libs"
+- if test "@libdir@" != "/usr/lib" ; then
+- echo -L@libdir@ $libs
+- else
+- echo $libs
+- fi
++ echo $libs
+ else
+ echo $libs
+ fi
diff --git a/media-libs/libafterimage/files/libafterimage-gif.patch b/media-libs/libafterimage/files/libafterimage-gif.patch
new file mode 100644
index 000000000000..8a2ca8e46720
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-gif.patch
@@ -0,0 +1,18 @@
+--- configure.in.orig 2011-03-28 18:55:22.000000000 +0100
++++ configure.in 2011-03-28 18:56:08.000000000 +0100
+@@ -60,12 +60,9 @@
+ dnl# AC_ARG_WITH(xpm_includes, [ --with-xpm-includes=DIR use libXpm includes in DIR( when builtin XPM handling is disabled )], xpm_includes="$withval", xpm_includes=no)
+
+ dnl# standard libgif/ungif should not be used and considered obsolete!
+-dnl# AC_ARG_WITH(ungif, [ --with-ungif support Uncompressed GIF image format using libungif [no]],with_ungif="$withval",with_ungif=no)
+-dnl# AC_ARG_WITH(gif, [ --with-gif support GIF image format using libgif [no]],with_gif="$withval",with_gif=no)
+-dnl# AC_ARG_WITH(gif_includes, [ --with-gif-includes=DIR use GIF includes in DIR], gif_includes="$withval", gif_includes=no)
+-with_ungif=no
+-with_gif=no
+-with_gif_includes=no
++AC_ARG_WITH(ungif, [ --with-ungif support Uncompressed GIF image format using libungif [no]],with_ungif="$withval",with_ungif=no)
++AC_ARG_WITH(gif, [ --with-gif support GIF image format using libgif [no]],with_gif="$withval",with_gif=no)
++AC_ARG_WITH(gif_includes, [ --with-gif-includes=DIR use GIF includes in DIR], gif_includes="$withval", gif_includes=no)
+ AC_ARG_WITH(builtin_gif, [ --with-builtin-gif support Uncompressed GIF image format using builtin libgif [yes]],with_builtin_gif="$withval",with_builtin_gif=yes)
+
+
diff --git a/media-libs/libafterimage/files/libafterimage-giflib42.patch b/media-libs/libafterimage/files/libafterimage-giflib42.patch
new file mode 100644
index 000000000000..b1b1f7263da1
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-giflib42.patch
@@ -0,0 +1,19 @@
+Fix build failure with giflib 4.2.
+Patch by Andrew Savchenko <bircoph@gmail.com>.
+https://bugs.gentoo.org/486804
+
+--- libAfterImage-1.20/ungif.h.orig
++++ libAfterImage-1.20/ungif.h
+@@ -7,6 +7,12 @@
+ extern "C" {
+ #endif
+
++#if (GIFLIB_MAJOR>4) || ((GIFLIB_MAJOR==4) && (GIFLIB_MINOR>=2))
++static inline void PrintGifError(void) {
++ fprintf(stderr, "%s\n", GifErrorString());
++}
++#endif
++
+ #ifdef __GNUC__
+ #define ASIM_PrintGifError() do{ fprintf( stderr, "%s():%d:<%s> ",__FUNCTION__, __LINE__, path?path:"null" ); PrintGifError(); }while(0)
+ #else
diff --git a/media-libs/libafterimage/files/libafterimage-libpng15.patch b/media-libs/libafterimage/files/libafterimage-libpng15.patch
new file mode 100644
index 000000000000..44d5b944007c
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-libpng15.patch
@@ -0,0 +1,31 @@
+--- export.c
++++ export.c
+@@ -496,7 +496,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
+--- import.c
++++ import.c
+@@ -1251,7 +1251,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+
+@@ -1468,7 +1468,7 @@
+
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
+ memcpy(data, buf->buffer, length);
+ buf->buffer += length;
+ }
diff --git a/media-libs/libafterimage/files/libafterimage-makefile.in.patch b/media-libs/libafterimage/files/libafterimage-makefile.in.patch
new file mode 100644
index 000000000000..a41f90a64c58
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-makefile.in.patch
@@ -0,0 +1,62 @@
+--- Makefile.in.orig 2005-08-16 10:00:02.000000000 +0200
++++ Makefile.in 2005-08-16 10:00:35.000000000 +0200
+@@ -79,7 +79,7 @@
+ MV = @MV@
+ RM = @RM@
+ RMF = @RM@ -f
+-MKDIR = @MKDIR@
++MKDIR = @MKDIR@ -p
+ FIND = @FIND@
+ XARGS = @XARGS@
+ LDCONFIG = @LDCONFIG@
+@@ -135,20 +135,6 @@
+ @(if [ -d $(LIBDIR) ] && [ -w $(LIBDIR) ]; then \
+ echo "$(INSTALL_LIB) $(LIB_STATIC) $(LIBDIR)"; \
+ $(INSTALL_LIB) $(LIB_STATIC) $(LIBDIR); \
+- if [ `uname` = "Linux" ]; then \
+- if test $(LIBDIR) = "/lib" || test $(LIBDIR) = "/usr/lib"; then \
+- echo "" > /dev/null; \
+- elif grep -q $(LIBDIR) /etc/ld.so.conf > /dev/null 2>&1; then \
+- echo "" > /dev/null; \
+- else \
+- echo "Unable to find $(LIBDIR) in ld.so.conf. In order to use "; \
+- echo "$(LIB_STATIC), you may need to add it or set LD_LIBRARY_PATH."; \
+- fi; \
+- if test -w /etc; then \
+- echo "$(LDCONFIG)"; \
+- $(LDCONFIG); \
+- fi; \
+- fi ;\
+ fi \
+ )
+
+@@ -161,18 +147,6 @@
+ $(RM) -f $(LIBDIR)/$(LIB_SHARED).$(LIBVERMAJOR) $(LIBDIR)/$(LIB_SHARED); \
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIBDIR)/$(LIB_SHARED).$(LIBVERMAJOR); \
+ $(LN_S) -f $(LIB_SHARED).$(LIBVERMAJOR) $(LIBDIR)/$(LIB_SHARED); \
+- if test `uname` = "Linux"; then \
+- if test $(LIBDIR) = "/lib" || test $(LIBDIR) = "/usr/lib"; then \
+- echo "" > /dev/null; \
+- elif grep -q $(LIBDIR) /etc/ld.so.conf > /dev/null 2>&1; then \
+- echo "" > /dev/null; \
+- else \
+- echo "Unable to find $(LIBDIR) in ld.so.conf. In order to use "; \
+- echo "$(LIB_SHARED), you may need to add it or set LD_LIBRARY_PATH."; \
+- fi; \
+- echo "$(LDCONFIG)"; \
+- $(LDCONFIG); \
+- fi \
+ )
+
+ install.cyg:
+@@ -393,8 +366,8 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS) config.h
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+- $(LIB_OBJS)
++ $(CC) -shared $(USER_LD_FLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(LIB_OBJS) $(LIBRARIES)
+
+ install.man:
+ @if [ -d doc/man ] ; then \
diff --git a/media-libs/libafterimage/libafterimage-1.20.ebuild b/media-libs/libafterimage/libafterimage-1.20.ebuild
new file mode 100644
index 000000000000..9b5da9c5e98c
--- /dev/null
+++ b/media-libs/libafterimage/libafterimage-1.20.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+MY_PN=libAfterImage
+
+DESCRIPTION="Afterstep's standalone generic image manipulation library"
+HOMEPAGE="http://www.afterstep.org/afterimage/index.php"
+SRC_URI="ftp://ftp.afterstep.org/stable/${MY_PN}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="examples gif jpeg cpu_flags_x86_mmx nls png static-libs svg tiff truetype"
+
+RDEPEND="
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXrender
+ png? ( >=media-libs/libpng-1.4:0 )
+ jpeg? ( virtual/jpeg )
+ gif? ( media-libs/giflib )
+ svg? ( gnome-base/librsvg )
+ tiff? ( media-libs/tiff:0 )
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ !!x11-wm/afterstep"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # fix some ldconfig problem in makefile.in
+ epatch "${FILESDIR}"/${PN}-makefile.in.patch
+ # fix lib paths in afterimage-config
+ epatch "${FILESDIR}"/${PN}-config.patch
+ # fix gif unbundle
+ epatch "${FILESDIR}"/${PN}-gif.patch
+ # fix for libpng15 compability
+ epatch "${FILESDIR}"/${PN}-libpng15.patch
+ # fix for gif library bug #486804
+ epatch "${FILESDIR}"/${PN}-giflib42.patch
+ # do not build examples
+ sed -i \
+ -e '/^all:/s/apps//' \
+ -e '/^install:/s/install.apps//' \
+ Makefile.in || die
+ # remove forced flags
+ sed -i \
+ -e 's/CFLAGS="-O3"//' \
+ -e 's/ -rdynamic//' \
+ configure.in || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs staticlibs) \
+ $(use_enable nls i18n) \
+ $(use_enable cpu_flags_x86_mmx mmx-optimization) \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with gif) \
+ $(use_with svg) \
+ $(use_with tiff) \
+ $(use_with truetype ttf) \
+ --enable-glx \
+ --enable-sharedlibs \
+ --with-x \
+ --with-xpm \
+ --without-builtin-gif \
+ --without-builtin-jpeg \
+ --without-builtin-png \
+ --without-builtin-zlib \
+ --without-afterbase
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ AFTER_DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ install
+ dodoc ChangeLog README
+ if use examples; then
+ cd apps || die
+ emake clean
+ rm Makefile* || die
+ insinto /usr/share/doc/${PF}/examples
+ doins *
+ fi
+}
diff --git a/media-libs/libafterimage/metadata.xml b/media-libs/libafterimage/metadata.xml
new file mode 100644
index 000000000000..7a85a428b17d
--- /dev/null
+++ b/media-libs/libafterimage/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang='en'>
+ libAfterImage is a generic image manipulation library.
+ It was initially implemented to address AfterStep Window Manager's needs for
+ image handling, but it evolved into software suitable for project
+ that has needs for handling images. Most of the popular image formats are
+ supported using standard libraries, with XCF, XPM, PPM/PNM, BMP, ICO,
+ TGA and GIF being supported internally. PNG, JPEG and TIFF formats are
+ supported via standard libraries. Text rendering capabilities
+ included, providing support for TrueType fonts using FreeType library,
+ and anti-aliasing of standard fonts from X window system.
+</longdescription>
+</pkgmetadata>