summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libbmp')
-rw-r--r--media-libs/libbmp/Manifest1
-rw-r--r--media-libs/libbmp/libbmp-0.1.3.ebuild28
-rw-r--r--media-libs/libbmp/metadata.xml11
3 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libbmp/Manifest b/media-libs/libbmp/Manifest
new file mode 100644
index 000000000000..f96c2364097c
--- /dev/null
+++ b/media-libs/libbmp/Manifest
@@ -0,0 +1 @@
+DIST libbmp-0.1.3.tar.bz2 254442 SHA256 57e0101262f3ae9676bd6d9f44e6038d936ffa450cc2ef72295c37f51b072320 SHA512 70eb81832c16b9ebd7005a643efe0362c91389d91ab9a9d5d7456b3bb87f508c3b56f12d4c6a546c60f263f656ff6a00145b31f7bb997921c552664b9bfbbd74 WHIRLPOOL 4d4464062295a463a591a7942cd9c0b64a2bfd389317a6a2c435fd997b1a1687bd49bf47fba6b1c3004cb0aebb3e5abc1f7419ffd114c69b2799b33bcbb4a61b
diff --git a/media-libs/libbmp/libbmp-0.1.3.ebuild b/media-libs/libbmp/libbmp-0.1.3.ebuild
new file mode 100644
index 000000000000..baeec2e7588a
--- /dev/null
+++ b/media-libs/libbmp/libbmp-0.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="C library for reading, writing, and modifying Windows bitmap image files"
+HOMEPAGE="http://code.google.com/p/libbmp/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/libbmp/metadata.xml b/media-libs/libbmp/metadata.xml
new file mode 100644
index 000000000000..e4a273bfa4cf
--- /dev/null
+++ b/media-libs/libbmp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+<longdescription lang="en">
+libbmp is a simple, cross-platform, open source (revised LGPL) C library designed for easily reading, writing, and modifying Windows bitmap (BMP) image files. The library is oriented towards the novice programmer with little formal experience, but it is sufficiently capable for anybody who desires to do I/O and pixel operations on uncompressed 1, 4, 8, 16, 24, and 32 bpp (bits per pixel) BMP files.
+</longdescription>
+</pkgmetadata>