summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libdvdnav/libdvdnav-9999.ebuild')
-rw-r--r--media-libs/libdvdnav/libdvdnav-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libdvdnav/libdvdnav-9999.ebuild b/media-libs/libdvdnav/libdvdnav-9999.ebuild
new file mode 100644
index 000000000000..0b7327707abd
--- /dev/null
+++ b/media-libs/libdvdnav/libdvdnav-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="Library for DVD navigation tools"
+HOMEPAGE="http://dvdnav.mplayerhq.hu/"
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.videolan.org/libdvdnav.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://downloads.videolan.org/pub/videolan/libdvdnav/${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86
+ ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos
+ ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libdvdread-5.0.2[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r4
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig" # To get pkg.m4 for eautoreconf #414391
+
+DOCS=( AUTHORS ChangeLog doc/dvd_structures doc/library_layout README TODO )