summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libheif/libheif-1.5.1.ebuild')
-rw-r--r--media-libs/libheif/libheif-1.5.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-libs/libheif/libheif-1.5.1.ebuild b/media-libs/libheif/libheif-1.5.1.ebuild
index e737b4ce1e4f..ea2fa1ddafbe 100644
--- a/media-libs/libheif/libheif-1.5.1.ebuild
+++ b/media-libs/libheif/libheif-1.5.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
inherit autotools xdg-utils multilib-minimal
@@ -34,6 +34,10 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
+ # heif_test.go is not included in the tarball
+ # https://github.com/strukturag/libheif/issues/289
+ cp "${FILESDIR}/heif_test.go" "${S}/go/heif" || die
+
sed -i -e 's:-Werror::' \
configure.ac || die
@@ -51,6 +55,11 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
+multilib_src_test() {
+ default
+ emake -C go test
+}
+
multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
if ! use static-libs ; then