summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-12.0.3.ebuild')
-rw-r--r--media-libs/mesa/mesa-12.0.3.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-12.0.3.ebuild b/media-libs/mesa/mesa-12.0.3.ebuild
index fd6b44d3b2d7..0ea1fe2d1db0 100644
--- a/media-libs/mesa/mesa-12.0.3.ebuild
+++ b/media-libs/mesa/mesa-12.0.3.ebuild
@@ -131,9 +131,14 @@ RDEPEND="${RDEPEND}
video_cards_radeonsi? ( ${LIBDRM_DEPSTRING}[video_cards_amdgpu] )
"
+# FIXME: kill the sys-devel/llvm[video_cards_radeon] compat once
+# LLVM < 3.9 is out of the game
DEPEND="${RDEPEND}
llvm? (
- video_cards_radeonsi? ( sys-devel/llvm[video_cards_radeon] )
+ video_cards_radeonsi? ( || (
+ sys-devel/llvm[llvm_targets_AMDGPU]
+ sys-devel/llvm[video_cards_radeon]
+ ) )
)
opencl? (
>=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]