summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index f7e39297e11b..74b4cf7fa906 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -44,11 +44,11 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gcrypt gles1 gles2
- +llvm nettle +nptl opencl osmesa pax_kernel openmax +openssl pic selinux
- vaapi valgrind vdpau wayland xvmc xa kernel_FreeBSD"
+ libressl +llvm nettle +nptl opencl osmesa pax_kernel openmax +openssl pic
+ selinux vaapi valgrind vdpau wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
- || ( gcrypt nettle openssl )
+ || ( gcrypt libressl nettle openssl )
d3d9? ( dri3 gallium )
llvm? ( gallium )
opencl? ( gallium llvm )
@@ -104,7 +104,10 @@ RDEPEND="
nettle? ( dev-libs/nettle:=[${MULTILIB_USEDEP}] )
!nettle? (
gcrypt? ( dev-libs/libgcrypt:=[${MULTILIB_USEDEP}] )
- !gcrypt? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
+ !gcrypt? (
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ !libressl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
+ )
)
opencl? (
app-eselect/eselect-opencl