summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opusfile/opusfile-0.4.ebuild')
-rw-r--r--media-libs/opusfile/opusfile-0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/opusfile/opusfile-0.4.ebuild b/media-libs/opusfile/opusfile-0.4.ebuild
new file mode 100644
index 000000000000..26cab4a9d906
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="http://www.opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+IUSE="doc fixed-point +float +http static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable fixed-point)\
+ $(use_enable float) \
+ $(use_enable http) \
+ $(use_enable static-libs static)
+}