summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sge/files')
-rw-r--r--media-libs/sge/files/sge-030809-build.patch8
-rw-r--r--media-libs/sge/files/sge-030809-freetype.patch4
-rw-r--r--media-libs/sge/files/sge-030809-freetype_pkgconfig.patch25
3 files changed, 31 insertions, 6 deletions
diff --git a/media-libs/sge/files/sge-030809-build.patch b/media-libs/sge/files/sge-030809-build.patch
index 5b277a0a6b08..4ded0888a7f3 100644
--- a/media-libs/sge/files/sge-030809-build.patch
+++ b/media-libs/sge/files/sge-030809-build.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2006-03-29 00:08:39.000000000 -0500
-+++ Makefile 2006-03-29 00:09:36.000000000 -0500
+--- a/Makefile
++++ b/Makefile
@@ -2,7 +2,7 @@
include Makefile.conf
@@ -95,8 +95,8 @@
ln -sf libSGE.so.$(API_VER).$(SGE_VER) libSGE.so.$(API_VER);\
ln -sf libSGE.so.$(API_VER) libSGE.so
@echo "** Headerfiles installed in $(PREFIX_H)"
---- Makefile.conf.orig 2006-03-29 00:08:39.000000000 -0500
-+++ Makefile.conf 2006-03-29 00:08:39.000000000 -0500
+--- a/Makefile.conf
++++ b/Makefile.conf
@@ -11,6 +11,7 @@
# Compilers (C and C++)
CC=gcc
diff --git a/media-libs/sge/files/sge-030809-freetype.patch b/media-libs/sge/files/sge-030809-freetype.patch
index 7b638e4100f9..f07ce98256a5 100644
--- a/media-libs/sge/files/sge-030809-freetype.patch
+++ b/media-libs/sge/files/sge-030809-freetype.patch
@@ -1,5 +1,5 @@
---- sge_tt_text.cpp
-+++ sge_tt_text.cpp
+--- a/sge_tt_text.cpp
++++ b/sge_tt_text.cpp
@@ -36,10 +36,9 @@
#include "sge_textpp.h"
diff --git a/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch b/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..ceb478f3d828
--- /dev/null
+++ b/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/655798
+
+--- sge030809/Makefile.conf
++++ sge030809/Makefile.conf
+@@ -35,16 +35,16 @@
+ SGE_LIBS =$(shell sdl-config --libs) -lstdc++
+
+
+-# Is freetype-config available?
+-HAVE_FT =$(shell if (freetype-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
++# Is freetype available?
++HAVE_FT =$(shell if pkg-config --exists freetype2 ; then echo "y"; else echo "n"; fi;)
+ ifeq ($(HAVE_FT),n)
+ USE_FT = n
+ endif
+
+ ifneq ($(USE_FT),n)
+ USE_FT = y
+- SGE_LIBS +=$(shell freetype-config --libs)
+- FT_CFLAGS =$(shell freetype-config --cflags)
++ SGE_LIBS +=$(shell pkg-config --libs freetype2)
++ FT_CFLAGS =$(shell pkg-config --cflags freetype2)
+ endif
+
+