summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch')
-rw-r--r--media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch b/media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch
new file mode 100644
index 000000000000..77d643593b47
--- /dev/null
+++ b/media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch
@@ -0,0 +1,40 @@
+Index: stk-4.5.0/Makefile.in
+===================================================================
+--- stk-4.5.0.orig/Makefile.in
++++ stk-4.5.0/Makefile.in
+@@ -6,35 +6,14 @@ REALTIME = @realtime@
+
+ all :
+ cd src && $(MAKE)
+- cd projects/demo && $(MAKE) libdemo
+-ifeq ($(REALTIME),yes)
+- cd projects/effects && $(MAKE) libeffects
+- cd projects/ragamatic && $(MAKE) libragamat
+- cd projects/eguitar && $(MAKE) libeguitar
+-endif
+- cd projects/examples && $(MAKE) -f libMakefile
+
+ clean :
+ $(RM) -f *~
+ cd src && $(MAKE) clean
+- cd projects/demo && $(MAKE) clean
+-ifeq ($(REALTIME),yes)
+- cd projects/effects && $(MAKE) clean
+- cd projects/ragamatic && $(MAKE) clean
+- cd projects/eguitar && $(MAKE) clean
+-endif
+- cd projects/examples && $(MAKE) clean
+
+ distclean: clean
+ $(RM) -rf config.log config.status autom4te.cache Makefile
+ cd src && $(MAKE) distclean
+- cd projects/demo && $(MAKE) distclean
+-ifeq ($(REALTIME),yes)
+- cd projects/effects && $(MAKE) distclean
+- cd projects/ragamatic && $(MAKE) distclean
+- cd projects/eguitar && $(MAKE) distclean
+-endif
+- cd projects/examples && $(MAKE) distclean
+
+ install:
+ $(MAKE) -C src install