summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-theora/gst-plugins-theora-0.10.36-r1.ebuild')
-rw-r--r--media-plugins/gst-plugins-theora/gst-plugins-theora-0.10.36-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-theora/gst-plugins-theora-0.10.36-r1.ebuild b/media-plugins/gst-plugins-theora/gst-plugins-theora-0.10.36-r1.ebuild
new file mode 100644
index 000000000000..d0212bdc5627
--- /dev/null
+++ b/media-plugins/gst-plugins-theora/gst-plugins-theora-0.10.36-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-base
+inherit gstreamer
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}]
+ >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ gstreamer_system_link \
+ gst-libs/gst/tag:gstreamer-tag \
+ gst-libs/gst/video:gstreamer-video
+}