summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild')
-rw-r--r--media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild
new file mode 100644
index 000000000000..d429da391536
--- /dev/null
+++ b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.36-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-base
+inherit gstreamer
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
+
+# xshm is a compile time option of ximage, which is in libXext
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"
+
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+
+ gstreamer_system_link \
+ gst-libs/gst/video:gstreamer-video \
+ gst-libs/gst/interfaces:gstreamer-interfaces
+}