summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch')
-rw-r--r--media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch b/media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch
new file mode 100644
index 000000000000..03acf6a20586
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.4.2-disable-ccache.patch
@@ -0,0 +1,19 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4ff5430..9c9dbf6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -69,14 +69,6 @@ set( CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake-proxies/cmake-modules)
+ set( CMAKE_CXX_STANDARD 14 )
+ set( CMAKE_CXX_STANDARD_REQUIRED ON )
+
+-# Use ccache if available
+-find_program( CCACHE_PROGRAM ccache )
+-mark_as_advanced( FORCE CCACHE_PROGRAM )
+-
+-if( CCACHE_PROGRAM )
+- set_property( GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}" )
+-endif()
+-
+ # Our very own project
+ project( Audacity )
+