summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild')
-rw-r--r--media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild b/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..7d1940c6de35
--- /dev/null
+++ b/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+IUSE=""
+
+DESCRIPTION="sync up 2 audio ch. and/or combine 2 mono audio ch. into one stereo wave ch"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ # fix makefile
+ sed -i -e "s:gcc:\$(CC):g" -e "s:= -O2:+=:g" \
+ -e "s:\( -o \): \$(LDFLAGS)\1:g" Makefile
+ epatch "${FILESDIR}"/${P}-overflow.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin combine_wave || die
+ dodoc CHANGES README combine_wave.man
+}