summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/denonavr-cli/denonavr-cli-3.ebuild')
-rw-r--r--media-sound/denonavr-cli/denonavr-cli-3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/denonavr-cli/denonavr-cli-3.ebuild b/media-sound/denonavr-cli/denonavr-cli-3.ebuild
new file mode 100644
index 000000000000..a5e29f2af9bc
--- /dev/null
+++ b/media-sound/denonavr-cli/denonavr-cli-3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple CLI for Denon AV receivers"
+HOMEPAGE="
+ https://github.com/mgorny/denonavr-cli/
+ https://pypi.org/project/denonavr-cli/
+"
+SRC_URI="
+ https://github.com/mgorny/denonavr-cli/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/denonavr[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest