summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/frescobaldi/frescobaldi-2.18.2.ebuild')
-rw-r--r--media-sound/frescobaldi/frescobaldi-2.18.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-2.18.2.ebuild b/media-sound/frescobaldi/frescobaldi-2.18.2.ebuild
new file mode 100644
index 000000000000..ef00cb602676
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-2.18.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="http://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain" # public-domain is for bundled Tango icons
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portmidi"
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ >=dev-python/python-ly-0.9.3[${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2
+ portmidi? ( media-libs/portmidi[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}