summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/frescobaldi')
-rw-r--r--media-sound/frescobaldi/Manifest1
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/Manifest b/media-sound/frescobaldi/Manifest
index 5bf3a43906b1..7669373d8068 100644
--- a/media-sound/frescobaldi/Manifest
+++ b/media-sound/frescobaldi/Manifest
@@ -1 +1,2 @@
DIST frescobaldi-2.20.0.tar.gz 4478977 BLAKE2B bac6e455656064fc64120a4e30690b55159254562f1b4fb6515fccb74cc113354ac337c68fe91942c42b4aeff14db18f5024dd6b47fb913dafe7bcf95efaf019 SHA512 a875e8d574e77db5e87555aa091b4b0966e4b8df16dc1f7fbcfe100f67d9ccafdd9a26c8f4b8cea13410faaa298185c1ec0e9b5e722b3d37c32d0b573511a3e3
+DIST frescobaldi-3.0.0.tar.gz 4895317 BLAKE2B 6a9a2b92d075742f54b3148761f1946c4dd73616482aec9278c0326d5597773ce6eb714f8d31d49f79051294d23d4e43552ce29bde0f464d1a677900b8a276f6 SHA512 e33cbcb70bec74239cd84691725e9978b6c6fee391848c7de8ea32dd5459d953ddda120eeea25a602154d94a84947b6c151237b859450162db0822ef58fd7787
diff --git a/media-sound/frescobaldi/frescobaldi-3.0.0.ebuild b/media-sound/frescobaldi/frescobaldi-3.0.0.ebuild
new file mode 100644
index 000000000000..d6cb86b3d468
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="http://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# portmidi? ( media-libs/portmidi[${PYTHON_USEDEP}] ) # bug 550820
+DEPEND="
+ dev-python/PyQt5[svg,${PYTHON_USEDEP}]
+ >=dev-python/python-ly-0.9.4[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}