summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/muse/muse-0.9.2.ebuild')
-rw-r--r--media-sound/muse/muse-0.9.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/muse/muse-0.9.2.ebuild b/media-sound/muse/muse-0.9.2.ebuild
new file mode 100644
index 000000000000..09fb0f8d6436
--- /dev/null
+++ b/media-sound/muse/muse-0.9.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+MY_P=${P/muse/MuSE}
+
+DESCRIPTION="Multiple Streaming Engine, an icecast source streamer"
+HOMEPAGE="http://muse.dyne.org"
+SRC_URI="ftp://ftp.dyne.org/muse/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="debug gtk"
+
+RDEPEND="media-sound/lame
+ media-libs/libvorbis
+ media-libs/libsndfile
+ media-libs/libogg
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable gtk gtk2)
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS} -fpermissive" CFLAGS="${CFLAGS}" \
+ || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" docsdir="/usr/share/doc/${PF}" \
+ install || die "emake install failed."
+ prepalldocs
+}