summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pavucontrol/pavucontrol-1.0.ebuild')
-rw-r--r--media-sound/pavucontrol/pavucontrol-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/pavucontrol/pavucontrol-1.0.ebuild b/media-sound/pavucontrol/pavucontrol-1.0.ebuild
new file mode 100644
index 000000000000..519b82f2aa15
--- /dev/null
+++ b/media-sound/pavucontrol/pavucontrol-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Pulseaudio Volume Control, GTK based mixer for Pulseaudio"
+HOMEPAGE="http://freedesktop.org/software/pulseaudio/pavucontrol/"
+SRC_URI="http://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=dev-cpp/gtkmm-3.0:3.0
+ >=dev-libs/libsigc++-2.2:2
+ >=media-libs/libcanberra-0.16[gtk3]
+ >=media-sound/pulseaudio-0.9.16[glib]
+ virtual/freedesktop-icon-theme"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+DOCS="ChangeLog"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --disable-lynx \
+ $(use_enable nls)
+}