summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/puddletag/puddletag-1.0.5.ebuild')
-rw-r--r--media-sound/puddletag/puddletag-1.0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/puddletag/puddletag-1.0.5.ebuild b/media-sound/puddletag/puddletag-1.0.5.ebuild
new file mode 100644
index 000000000000..f165a6c5ee0c
--- /dev/null
+++ b/media-sound/puddletag/puddletag-1.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://puddletag.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acoustid cover musicbrainz quodlibet"
+
+DEPEND=""
+RDEPEND=">=dev-python/PyQt4-4.9.6-r2[${PYTHON_USEDEP},svg]
+ >=dev-python/pyparsing-1.5.1[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-1.21[${PYTHON_USEDEP}]
+ >=dev-python/configobj-4.7.2-r1[${PYTHON_USEDEP}]
+ acoustid? ( >=media-libs/chromaprint-0.6 )
+ musicbrainz? ( >=dev-python/python-musicbrainz-0.7.4-r1[${PYTHON_USEDEP}] )
+ cover? ( virtual/python-imaging[${PYTHON_USEDEP}] )
+ quodlibet? ( >=media-sound/quodlibet-2.5[${PYTHON_USEDEP}] )
+ >=dev-python/sip-4.14.2-r1:0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0.1[${PYTHON_USEDEP}]"
+
+DOCS=(changelog HACKING NEWS README THANKS TODO)
+
+PATCHES=("${FILESDIR}/${P}-pyqt4.11.4.patch")