summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch')
-rw-r--r--media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch b/media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch
new file mode 100644
index 000000000000..66a765a8b9ea
--- /dev/null
+++ b/media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch
@@ -0,0 +1,25 @@
+disabled the use of ccache, to prevent FTBFS; as the compilation is done once
+it has no backdraws to make the debian package.
+Index: supercollider/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -150,12 +150,12 @@ add_definitions(-DBOOST_CHRONO_HEADER_ON
+ #############################################
+ # Detect CCache
+
+-find_program(CCacheExectuable ccache)
+-if( CCacheExectuable )
+- # only used with >=cmake-3.4
+- set( CMAKE_C_COMPILER_LAUNCHER "${CCacheExectuable}" )
+- set( CMAKE_CXX_COMPILER_LAUNCHER "${CCacheExectuable}" )
+-endif()
++## find_program(CCacheExecutable ccache)
++## if( CCacheExecutable )
++## # only used with >=cmake-3.4
++## set( CMAKE_C_COMPILER_LAUNCHER "${CCacheExecutable}" )
++## set( CMAKE_CXX_COMPILER_LAUNCHER "${CCacheExecutable}" )
++## endif()
+
+ #############################################
+ # Options