summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/frameworks/frameworks-0.3.7-r1.ebuild')
-rw-r--r--media-video/frameworks/frameworks-0.3.7-r1.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/media-video/frameworks/frameworks-0.3.7-r1.ebuild b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
index 32b2c372bb81..bc2a76ae9d4e 100644
--- a/media-video/frameworks/frameworks-0.3.7-r1.ebuild
+++ b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
@@ -1,36 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools
DESCRIPTION="A small v4l frame capture utility especially suited for stop motion animation"
SRC_URI="http://frameworks.polycrystal.org/release/${P}.tar.gz"
HOMEPAGE="http://frameworks.polycrystal.org"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND="
>=gnome-base/libglade-2
- x11-libs/gtk+:2
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-DOCS=(
- AUTHORS ChangeLog NEWS README TODO
-)
PATCHES=(
- "${FILESDIR}"/${PN}-0.3.7-ceilf.patch
- "${FILESDIR}"/${PN}-0.3.7-strcmp-and-datadir.patch
+ "${FILESDIR}"/${P}-ceilf.patch
+ "${FILESDIR}"/${P}-strcmp-and-datadir.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
default
-
+ mv configure.{in,ac} || die
eautoreconf
}