summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/2ping/2ping-2.0.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-2.0.ebuild b/net-analyzer/2ping/2ping-2.0.ebuild
new file mode 100644
index 000000000000..ad1efe1932b9
--- /dev/null
+++ b/net-analyzer/2ping/2ping-2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="http://www.finnie.org/software/2ping/"
+SRC_URI="http://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crc ipv6 md5 sha server"
+
+# The 2ping script itself checks if these optional deps are available.
+DEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ virtual/perl-IO
+ virtual/perl-Time-HiRes
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ md5? ( virtual/perl-Digest-MD5 )
+ sha? ( virtual/perl-Digest-SHA )
+ crc? ( dev-perl/Digest-CRC )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc ChangeLog README
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}