summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/argus/files/argus-3.0.5-Makefile.patch')
-rw-r--r--net-analyzer/argus/files/argus-3.0.5-Makefile.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-analyzer/argus/files/argus-3.0.5-Makefile.patch b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
new file mode 100644
index 000000000000..87b1c155caf8
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
@@ -0,0 +1,20 @@
+Do not continue when a sub-make errors (bug #380953).
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -55,11 +55,11 @@
+ .PHONY: install installdirs all
+
+ all: force
+- @-for d in $(DIRS);\
++ @for d in $(DIRS);\
+ do \
+- (cd $$d; echo "### Making in" `pwd`;\
+- $(MAKE) $(MFLAGS) ;\
+- echo "### Done with" `pwd`);\
++ echo "### Making in" $$d;\
++ $(MAKE) -C $$d $(MFLAGS) || exit 1;\
++ echo "### Done with" $$d;\
+ done
+
+ install: force