summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arpoison/arpoison-0.6-r2.ebuild')
-rw-r--r--net-analyzer/arpoison/arpoison-0.6-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/arpoison/arpoison-0.6-r2.ebuild b/net-analyzer/arpoison/arpoison-0.6-r2.ebuild
new file mode 100644
index 000000000000..76c4dcaf915c
--- /dev/null
+++ b/net-analyzer/arpoison/arpoison-0.6-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to poison ARP caches"
+HOMEPAGE="http://arpoison.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+
+RDEPEND="net-libs/libnet:1.1"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # respect CFLAGS, LDFLAGS and compiler, bug #337896
+ # fix for crosscompilation, bug #375655
+ sed -i Makefile \
+ -e 's|gcc \(-Wall\)|$(CC) \1 $(CFLAGS) $(LDFLAGS)|' \
+ -e "s|libnet-config|${ROOT}usr/bin/libnet-config|g" \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin arpoison
+ doman arpoison.8
+ dodoc README TODO
+}