summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/bro/bro-2.4.1-r2.ebuild')
-rw-r--r--net-analyzer/bro/bro-2.4.1-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-analyzer/bro/bro-2.4.1-r2.ebuild b/net-analyzer/bro/bro-2.4.1-r2.ebuild
index 231ad94155e5..5170d3b253a6 100644
--- a/net-analyzer/bro/bro-2.4.1-r2.ebuild
+++ b/net-analyzer/bro/bro-2.4.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -44,6 +44,12 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_prepare() {
+ # Disable shell script feature which sets interpreter to build time default
+ find . -name "*.cmake" -exec sed -i -e "s:\${\${_shell}_interp}:/usr/bin/env ${EPYTHON}:g" {} + || die
+ cmake-utils_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_DEBUG=$(usex debug true false)