summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/bwping')
-rw-r--r--net-analyzer/bwping/Manifest1
-rw-r--r--net-analyzer/bwping/bwping-1.7-r1.ebuild28
-rw-r--r--net-analyzer/bwping/files/bwping-1.7-buildsystem-configurable-ipv6.patch55
-rw-r--r--net-analyzer/bwping/metadata.xml20
4 files changed, 104 insertions, 0 deletions
diff --git a/net-analyzer/bwping/Manifest b/net-analyzer/bwping/Manifest
new file mode 100644
index 000000000000..b2bc34a63695
--- /dev/null
+++ b/net-analyzer/bwping/Manifest
@@ -0,0 +1 @@
+DIST bwping-1.7.tar.gz 90441 SHA256 a73db87b47d363d722cd60473a546930a5e78df8d21437191ba4ca06d7197297 SHA512 74b695a80c2fa54693af1afab78417dc6ca35130bbd9367950681ddbbebe36b38166068532e8296f336c5cad8230339b4fb4fb975f4b066cdacba8a99179cac7 WHIRLPOOL 41567722306d0ee72bad2ba9802bf399f0b435848a11d075bb89f746487c06ab16484056f54223b5cbea26e2855f2273b52a1247743c7cc77ad89beb26c3da01
diff --git a/net-analyzer/bwping/bwping-1.7-r1.ebuild b/net-analyzer/bwping/bwping-1.7-r1.ebuild
new file mode 100644
index 000000000000..b3faf3c923f4
--- /dev/null
+++ b/net-analyzer/bwping/bwping-1.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A tool to measure bandwidth and RTT between two hosts using ICMP"
+HOMEPAGE="http://bwping.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~sparc x86 ~x86-fbsd"
+IUSE="ipv6"
+
+#PATCHES=(
+# "${FILESDIR}/${P}-buildsystem-configurable-ipv6.patch" # bug 454256
+#)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ipv6)
+ )
+ autotools-utils_src_configure
+}
diff --git a/net-analyzer/bwping/files/bwping-1.7-buildsystem-configurable-ipv6.patch b/net-analyzer/bwping/files/bwping-1.7-buildsystem-configurable-ipv6.patch
new file mode 100644
index 000000000000..306b2b9fd22c
--- /dev/null
+++ b/net-analyzer/bwping/files/bwping-1.7-buildsystem-configurable-ipv6.patch
@@ -0,0 +1,55 @@
+Index: bwping-1.7/configure.in
+===================================================================
+--- bwping-1.7.orig/configure.in
++++ bwping-1.7/configure.in
+@@ -32,9 +32,30 @@ AC_CHECK_FUNC(getaddrinfo)
+ if test $ac_cv_func_getaddrinfo = no; then
+ AC_SEARCH_LIBS(getaddrinfo, [nsl socket], [], [ echo "getaddrinfo() is required for build"; exit -1 ])
+ fi
+-AC_MSG_CHECKING(for IPv6 support)
+-AC_CACHE_VAL(ac_cv_ipv6,
+- AC_TRY_RUN([
++
++AC_ARG_ENABLE(ipv6,
++ AC_HELP_STRING([--disable-ipv6],[disable IPv6 support]),
++ [case "${enable_ipv6}" in
++ no)
++ ipv6=no
++ ;;
++ yes)
++ ipv6=yes
++ ;;
++ *)
++ AC_MSG_ERROR([Invalid --enable-ipv6 argument '$enable_ipv6'])
++ ;;
++ esac
++ ], [
++ dnl If nothing is specified, assume auto-detection
++ ipv6=yes
++ ]
++)
++
++if test $ipv6 = yes; then
++ AC_MSG_CHECKING(for IPv6 support)
++ AC_CACHE_VAL(ac_cv_ipv6,
++ AC_TRY_LINK([
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+@@ -54,9 +75,12 @@ main()
+ ac_cv_ipv6=yes,
+ ac_cv_ipv6=no,
+ ac_cv_ipv6=no))
+-AC_MSG_RESULT($ac_cv_ipv6)
+-if test $ac_cv_ipv6 = yes ; then
+- AC_DEFINE(IPV6,, "check if system supports IPV6")
++ if test $ac_cv_ipv6 = yes ; then
++ AC_DEFINE(IPV6,, "check if system supports IPV6")
++ else
++ AC_MSG_ERROR([IPv6 support was request, but not found])
++ fi
++ AC_MSG_RESULT($ac_cv_ipv6)
+ fi
+-AM_CONDITIONAL([BUILDIPV6], [ test $ac_cv_ipv6 = yes ])
++AM_CONDITIONAL([BUILDIPV6], [ test $ipv6 = yes ])
+ AC_OUTPUT(Makefile)
diff --git a/net-analyzer/bwping/metadata.xml b/net-analyzer/bwping/metadata.xml
new file mode 100644
index 000000000000..905c8f0a5329
--- /dev/null
+++ b/net-analyzer/bwping/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>oleg.derevenetz@gmail.com</email>
+ <name>Oleg Derevenetz</name>
+ </maintainer>
+ <remote-id type="sourceforge">bwping</remote-id>
+ </upstream>
+ <longdescription>
+ A tool to measure bandwidth and response times between two hosts using
+ Internet Control Message Protocol (ICMP) echo request/echo reply mechanism.
+ </longdescription>
+</pkgmetadata>