summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild')
-rw-r--r--net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild b/net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..cb7acceec937
--- /dev/null
+++ b/net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="netcat clone extended with twofish encryption"
+HOMEPAGE="http://cryptcat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-unix-${PV}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+
+S=${WORKDIR}/unix
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-misc.patch
+ tc-export CC CXX
+}
+
+src_install() {
+ dobin cryptcat
+ dodoc Changelog README README.cryptcat netcat.blurb
+}