summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-0.11.2.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.11.2.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
index 1c47a71b51d9..caf428f0ca77 100644
--- a/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
@@ -10,11 +10,16 @@ inherit bash-completion-r1 distutils-r1 systemd tmpfiles
DESCRIPTION="Scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm ~arm64 hppa ppc ppc64 sparc x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ppc ppc64 sparc x86"
IUSE="selinux systemd"
RDEPEND="
@@ -27,7 +32,7 @@ RDEPEND="
dev-python/python-systemd[${PYTHON_USEDEP}]
sys-apps/systemd[python(-),${PYTHON_USEDEP}]
)' 'python*' )
- )
+ )
"
DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
@@ -52,7 +57,10 @@ python_compile() {
}
python_test() {
- bin/fail2ban-testcases -n -g --verbosity=4 || die "Tests failed with ${EPYTHON}"
+ bin/fail2ban-testcases \
+ --no-network \
+ --no-gamin \
+ --verbosity=4 || die "Tests failed with ${EPYTHON}"
}
python_install_all() {
@@ -64,8 +72,8 @@ python_install_all() {
newconfd files/gentoo-confd ${PN}
newinitd files/gentoo-initd ${PN}
- sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
- systemd_dounit "${T}/${PN}.service"
+ sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}"/${PN}.service || die
+ systemd_dounit "${T}"/${PN}.service
dotmpfiles files/${PN}-tmpfiles.conf
doman man/*.{1,5}
@@ -87,13 +95,13 @@ pkg_preinst() {
}
pkg_postinst() {
- if [[ $previous_less_than_0_7 = 0 ]] ; then
+ if [[ ${previous_less_than_0_7} = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"
- elog "files before restarting Fail2ban!"
+ elog "files before restarting Fail2Ban!"
elog
- elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "Fail2Ban is not installed under /usr/lib anymore. The"
elog "new location is under /usr/share."
elog
elog "You are upgrading from version 0.6.x, please see:"