summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch')
-rw-r--r--net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch14
1 files changed, 12 insertions, 2 deletions
diff --git a/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch b/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch
index 39d325984245..aa6ea74ff93f 100644
--- a/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch
+++ b/net-analyzer/graphite-web/files/graphite-web-1.1.3-fhs-paths.patch
@@ -10,11 +10,12 @@ Install FHS-style paths
from graphite.wsgi import application
--- a/setup.py
+++ b/setup.py
-@@ -59,8 +59,7 @@
+@@ -59,8 +59,8 @@
],
package_data={'graphite' :
['templates/*', 'local_settings.py.example']},
- scripts=glob('bin/*'),
++ scripts=['bin/graphite-web-build-index'],
- data_files=list(webapp_content.items()) + storage_dirs + conf_files + examples,
+ data_files=list(webapp_content.items()),
install_requires=['Django>=1.8,<1.11.99', 'django-tagging==0.4.3', 'pytz', 'pyparsing', 'cairocffi', 'urllib3', 'scandir', 'six'],
@@ -36,7 +37,7 @@ Install FHS-style paths
#INDEX_FILE = '/opt/graphite/storage/index' # Search index file
+CONF_DIR = '@GENTOO_PORTAGE_EPREFIX@/etc/graphite-web'
+STORAGE_DIR = '@GENTOO_PORTAGE_EPREFIX@/var/lib/carbon'
-+STATIC_ROOT = '@GENTOO_PORTAGE_EPREFIX@/usr/share/graphite-web'
++STATIC_ROOT = '@GENTOO_PORTAGE_EPREFIX@/usr/share/graphite-web/webapp/content'
+LOG_DIR = '@GENTOO_PORTAGE_EPREFIX@/var/log/graphite-web'
+INDEX_FILE = '@GENTOO_PORTAGE_EPREFIX@/var/lib/graphite-web/index' # Search index file
@@ -51,3 +52,12 @@ Install FHS-style paths
#
# Data directories using the "Standard" metrics finder (i.e. not Ceres)
#STANDARD_DIRS = [WHISPER_DIR, RRD_DIR] # Default: set from the above variables
+@@ -244,7 +244,7 @@
+ #
+ #DATABASES = {
+ # 'default': {
+-# 'NAME': '/opt/graphite/storage/graphite.db',
++# 'NAME': '@GENTOO_PORTAGE_EPREFIX@/var/lib/graphite-web/graphite.db',
+ # 'ENGINE': 'django.db.backends.sqlite3',
+ # 'USER': '',
+ # 'PASSWORD': '',