summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hunt/files/hunt-1.5-flags.patch')
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-flags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-analyzer/hunt/files/hunt-1.5-flags.patch b/net-analyzer/hunt/files/hunt-1.5-flags.patch
new file mode 100644
index 000000000000..2ffcd823847e
--- /dev/null
+++ b/net-analyzer/hunt/files/hunt-1.5-flags.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,7 @@
+-CFLAGS=-Wall -O2 -g -D_REENTRANT
++CFLAGS += -I. -Wall -D_REENTRANT
+ #CFLAGS+=-DSYNC_FAST
+ #CFLAGS+=-D_WITH_LINUX_KERNEL_HDR
+
+-LDFLAGS=
+ #LDFLAGS=-static
+
+ OBJ=hunt.o main.o c/list.o c/hash.o c/array.o util.o net.o \
+@@ -11,7 +10,7 @@
+ addpolicy.o options.o resolv.o timer.o pktrelay.o
+
+ hunt: $(OBJ)
+- $(CC) ${LDFLAGS} -o $@ $^ -lpthread
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lpthread
+
+ hunt_static: $(OBJ)
+ $(CC) ${LDFLAGS} -static -o $@ $^ -lpthread