summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/icinga2/icinga2-9999.ebuild')
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index 92b7c65b3f1b..7243f8baa7c6 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -3,11 +3,11 @@
EAPI=6
if [[ ${PV} != 9999 ]]; then
- inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
+ inherit cmake-utils depend.apache eutils systemd toolchain-funcs wxwidgets
SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
else
- inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
+ inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs wxwidgets
EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
EGIT_BRANCH="master"
fi
@@ -41,7 +41,11 @@ RDEPEND="
net-analyzer/monitoring-plugins
net-analyzer/nagios-plugins
) )
- mail? ( virtual/mailx )"
+ mail? ( virtual/mailx )
+ acct-user/icinga
+ acct-group/icinga
+ acct-group/icingacmd
+ acct-group/nagios"
REQUIRED_USE="!minimal? ( || ( mariadb mysql postgres ) )"
@@ -49,10 +53,6 @@ want_apache2
pkg_setup() {
depend.apache_pkg_setup
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
}
src_configure() {