summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch')
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
new file mode 100644
index 000000000000..e2c14e6add71
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,7 @@
+ # Makefile for IFStatus
+ # Gabriel Montenegro
+
+-GCC = g++
+-LDFLAGS = -lncurses
+-CFLAGS = -O2 -Wall
++LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
+
+ BIN = ifstatus
+ OBJ = BorderDecorator.o\
+@@ -30,7 +28,7 @@
+ all : ifstatus printdone
+
+ ifstatus : $(OBJ)
+- $(GCC) $(CFLAGS) $(LDFLAGS) $^ -o $@
++ $(LINK.cc) $^ $(LDLIBS) -o $@
+
+ printdone:
+ @if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi