summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild')
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..f5cad000f1d8
--- /dev/null
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+KEYWORDS="amd64 arm ~ppc x86"
+
+DESCRIPTION="A simple CLI program for displaying network statistics in real time"
+HOMEPAGE="http://ifstatus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-4.2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-tinfo.patch"
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ dobin ifstatus
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
+}